×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

How to increase allocated RAM in ANSYS mechnical APDL

How to increase allocated RAM in ANSYS mechnical APDL

How to increase allocated RAM in ANSYS mechnical APDL

(OP)
Hi
I have accessibility to high speed computer ( CPU=24cores and RAM=32GB). I adjusted ansys mechnical apdl product launcher as follows:
high performance computing setup-Type performance computing-used shared memory parallel(SMP)-number of processor=20
when I run the simulation and check task manager I realized cpu uses cores up to 92% (it is ok) but used Ram was 3.5GB and it was less than 11%
is there any trick or method to increase allocated RAM?
it should be noted I manipulated custom memory setting as follows:
customization preferences-used custom memory setting-28000MB for total workspace, 14000MB for data base but no difference appeared in used RAM by ansys. and also elapsed time for solution in laptop (core i7, RAM=12GB) has not difference with high computer speed ( CPU=24cores and RAM=32GB) as if the effect of increase number of processors and RAM on solution time is nothing!!!!!
any comment would be appreciated.

RE: How to increase allocated RAM in ANSYS mechnical APDL

How big is your analysis?
I have only used ANSYS mechanical without the APDL. If the solver selection type is set to Auto, it attempts to use a direct solver where the entire analysis is loaded into RAM. If the analysis is to large, it will use the iterative solver which involves switching and moving sub parts of the analysis between RAM and virtual slow SSD drive RAM.
Due to the slow speed of a SSD drive, the iterative option takes about five times longer and often there is not enough RAM to even complete this.
It is possible that ANSYS has decided that it can't fit the entire analysis into your RAM, and is reverting to an iterative analysis. Perhaps you just don't have enough RAM.
I tend to just select Direct or Iterative and let ANSYS manage the RAM.
This is probably not much help to you. I'm waiting for a 64Gb upgradable to 128Gb machine to arrive where I won't need to mess around with this RAM issue so much.

RE: How to increase allocated RAM in ANSYS mechnical APDL

(OP)
Hey DriveMeNuts
in .stat file I have : Sparse Solver : curEqn= 37855 totEqn= 37855

RE: How to increase allocated RAM in ANSYS mechnical APDL

You can consider using BCSOPTION command. It may help.

BCSOPTION,,INCORE,,,,PERFORMANCE

For more details, check this link. The 'PERFORMANCE' option in command outputs amount of memory required to run in incore mode based o which you can do model changes after first run.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login



News


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close