×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Linux: Draftsight vs ????

Linux: Draftsight vs ????

Linux: Draftsight vs ????

(OP)
I have been using Draftsight for a few months and I like most things about the program. The esnap works well, toolbars for most of the common actions, command line keeps focus if you need to type location, and for many things it seems to use the fewest steps (compared to other CAD programs) to make a drawing. But I have some problems that prevent me from using Draftsight, random crashes, mouse lag, unable to print color (it worked before), and the config settings could be easier to navigate. I have tried other programs such as LibreCAD, ARES, ARCAD, and a few others, but so far the only one that seems to work well for me is BricsCAD. I would like to hear your opinion (good and bad) on CAD programs you have used in Linux before I spend a few dollars on one.

RE: Linux: Draftsight vs ????

I really liked Draftsight, and was able to make good use of it despite a few annoyances, but now I have to look for something else.

... because the version that was working just fine for me has timed out, and the newest version is not available/supported on 32 bit Linux systems.

Mike Halloran
Pembroke Pines, FL, USA

RE: Linux: Draftsight vs ????

(OP)
I bought BricsCAD Pro when the 30 day trial expired. I'm using 64 bit Ubuntu 14.04 and I don't know if they have 32 bit for linux, but here are some of the requirements Link You could try downloading it or send an email asking if a 32 bit version exists. I would have paid for Draftsight had it not crashed randomly.

RE: Linux: Draftsight vs ????

I've just downloaded and installed Medusa4 Personal 5.2.1, which is a 32 bit app, and installs to Linux using a big script and an automatically generated and emailed license file keyed to your network adapter.

Like its predecessors, it doesn't really fit well on my laptop's 1024x768 screen. It seems to assume the screen is much bigger. I think I found a setting that shrunk the display to the correct size in a previous version. I wish I had written that down, or remember where/if I did.
I'll put another copy on my desktop, which has a bigger screen. Draftsight used to work fairly well on the small screen.

Medusa managed to open a few AC14 .DWG files that I had. I think there's some 3D information in them; they didn't cause Medusa to crash, but there seems to be no way to rotate the display to visualize the perspective.

I honestly don't know if Medusa is displaying everything that was in the files, because it's been so long since I generated them.

Medusa4 Personal is billed as full 2D/partial 3D, but so far I haven't been able to find a 3D anything. Maybe I should read the manual...


Mike Halloran
Pembroke Pines, FL, USA

RE: Linux: Draftsight vs ????

Hi,

I've used IntelliCAD products like BricsCAD and CADopia, but these products did not run that well under Ubuntu. I've migrated to Fedora since and have been using DraftSight on my Fedora Linux computers (desktop and laptop), and Windows machines at work, for about 3 years.

For the colour printing issue, I too had it printing to my Brother MFC-J6510DW colour 11"x17" printer and then it started only printing in black and white. The issue is not with DraftSight but with the printer driver. Here is the work around: print to pdf format first, then print the pdf format to same printer and colours are there; plus you have a "revision snapshot" of the drawing in pdf format, which may save your bacon if you need to present the drawing and your computer crashed or such.

The only thing is that, if the drawing is not a schematic, and scale matters, you have to make sure that the pdf printing paramaters to not stretch the drawing to "fit" the paper format.

For the mouse lag : never had this, I suspect you lack in RAM or CPU bandwidth. Possibly shutdown other applications while using DraftSight. Possibly time to upgrade your hardware or get another (used?) machine with more power.

For screen issue: many laptops, even in older models, have a video port for an external screen. Today it's possible to purchase a used screen of a decent size and resolution for little money.

I had two IntelliCAD licences that I have abandonned for Draftsight with no regrets.

The only thing that confuses me in DraftSight is the management of Paper space versus Model space, when you're trying to setup a printing view. Can't seem to find a toggle or state indicator; changing paper sizes is also not obvious for me. Anyone?

Hope this helps and maybe one of you can help me with my paper size management and space mode toggling / indication.

Cheers,


xian
(Christian)

Best Regards,


Christian Martel, P. Eng. PMP

RE: Linux: Draftsight vs ????

For other reasons, I bought a new computer, an HP laptop with lots of RAM and a 64 bit processor. It came with Windows 7 Pro, which I am trying to ignore.

I installed CentOS6, which is basically RHEL with no support. Fine.
Next problem: The least inappropriate Draftsight version available, 64 bits now, is for Fedora.
It downloads and seems to install without problems, shows up in the proper menu position, and ... does nothing. It will not start. It is properly associated with the DWG file type, and it won't launch that way either. There are no messages of any kind produced.

I gave up on Fedora long ago, because it's a bleeding edge kind of thing, gets updated very often, and the updates often break stuff. Not often like Microsoft updates blowing up, but often enough to be aggravating. I prefer CentOS, which evolves more slowly.

... but now, I'll have to reboot into that accursed Windows and use Draftsight there, in Bill's Bizzarro world. Yecch.

Dassault, are you listening? Please support CentOS.


Mike Halloran
Pembroke Pines, FL, USA

RE: Linux: Draftsight vs ????

More on CentOS and Draftsight:

Using YUM to install Draftsight in CentOS 6.6 appears to work, in the sense that no error messages result,
and doesn't work, in the sense that nothing appears to happen when you try to start Draftsight.

The installed Draftsight (draftsight-2015.3.0.3019-1.x86_64 ) won't start.
Trying to start it from the command line
$ /opt/dassault-systemes/DraftSight/Linux/DraftSight
reveals that Draftsight expects to find:
GLIBC_2.14
and
GLIBCXX_3.4.15
,
neither of which are present in CentOS6.

So far as I can tell, they are not present in CentOS7, either, but I haven't actually tried that.
Those libraries are present in Fedora21, and I think in 20 and 19, so the Fedora rpm provided by Dassault
should work on Fedora 19-ish and higher. ... but not, alas, CentOS6.

Containers are alleged to solve library problems, but containers are no longer supported in CentOS6,
and I have found no evidence of anyone having used containers or anything else to get
Draftsight to run on CentOS7.

I tried a live DVD of CentOS7, and hated the 'simplified' interface, and most everything else about it, so I'm not upgrading yet.

Can anyone report a successful install of Draftsight on Fedora, or Ubuntu, or OpenSuse, or .... ?

Mike Halloran
Pembroke Pines, FL, USA

RE: Linux: Draftsight vs ????

I have limited progress to report.

MeX Linux 64 bit Live version can be installed to a USB thumbdrive.
It is based on Linux Mint, which is based on Ubuntu.
http://mex.exton.net/
... and it occasionally boots. The same .iso boots better when installed to a DVD, but then you don't get persistence.
There seems to be some difficulty with the nouveau drivers for my nVidia card.
... and after squawking about some broken packages, and telling you how to get them fixed, the Ubuntu Draftsight .deb file will install on it, and it seems to work, and pretty fast.

So far, I haven't been able to get the persistence working, so I've had to reinstall Drafsight several times.
Also, it doesn't boot exactly the same way every time. The author includes some words about which thumbdrives work best.
You definitely want one with an activity light, which is not a given anymore, so you can tell when it's being written to, or at least have some idea that something is going on and the damn computer has not just gone off into the weeds.


Mike Halloran
Pembroke Pines, FL, USA

RE: Linux: Draftsight vs ????

BTW, I installed MeX using the scripts:
http://mex.exton.net/mex-usb-persistent/
from CentOS6.7.

I tried using YUMI in Windows7Pro to install a bunch of other distributions.
http://www.pendrivelinux.com/yumi-multiboot-usb-cr...
it seems to do a super job of installing 32 bit distribution live versions,
and sets up a nice boot menu so you can select from several at boot time,
and add or remove them at will under Windows.
It doesn't do that well with 64 bit distributions.
Some of them seemed to work, but really came up as 32 bit versions.
Some of them wouldn't boot at all.

Mike Halloran
Pembroke Pines, FL, USA

RE: Linux: Draftsight vs ????

I got MeX Linux (MeX 64 bit Linux (build 150714) based on Linux Mint 17.2 “Rafaela” with Cinnamon 2.6.13) persistence working, but it still takes many attempts to boot from a USB stick, and produces lots of error messages during the process, most related to the open source nouveau driver for my nvidia graphics card. The good news is that Draftsight installs without errors from the Ubuntu .deb file, survives a reboot, and seems to work so far.

The newer, 'better' version of Linux from the same author, called ExTiX 15.3 with LXQt 0.9.0 and kernel 4.1.0-3-exton, boots much more reliably, and the persistence works, but it absolutely refuses to install the Draftsight .deb file.
I tried that 'distro' because it allegedly comes with nvidia drivers installed by default, but attempts to adjust the nvidia settings produce messages that the nvidia drivers are not installed at all. Also, I like MeX' interface much better, but 'exton' alleges that the nVidia drivers don't get along with Gnome, so Gnome was replaced with LXQt.

The one 64 bit distribution for which I initially had hope is FatDog64, derived from Puppy Linux, which has a long history of working perfectly from USB sticks and multisession CDs with persistence, but FatDog's authors elected to build their own package manager, so FatDog can't use a .deb file or an .rpm file.

Such is the blessing, and the curse, of Linux. If you don't like it, wait ten minutes, and some random hobbyist will have released yet another new and improved version, that you may or may not like better, and which may or may not do anything useful, or anything at all.

You might want to install MeX and Draftsight on a USB stick while you still can. You'll need at least a 16Gb stick; 8Gb clearly isn't big enough.

Mike Halloran
Pembroke Pines, FL, USA

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login


Resources

White Paper - Considerations for choosing a 3D printing technology
The adoption of 3D printing into major companies’ product development life cycles is a testament to the technology’s incredible benefits to consumers, designers, engineers and manufacturers. While traditional production methods have limitations in manufacturability, 3D printing provides unparalleled design freedom due to the additive method of building parts layer by layer. Download Now
White Paper - Are all 3D printed metals the same?
With so many different 3D printing metal systems and processes today, how can you know exactly what you’re getting? Today, there are several different methods for manufacturing 3D printed metal components with their own strengths and limits. Download Now

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close