×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Create DLL file in ADAMS

Create DLL file in ADAMS

Create DLL file in ADAMS

(OP)
I want to create DLL file for using in ADAMS at motion, so i found a code in Fortran with name motsub1.f, I am beginner in Fortran and just change of this code VALUE and do steps in image to create DLL of it, but i get error, what is ifort and link.exe?


RE: Create DLL file in ADAMS

(OP)
yes, i run a sfosub_sample.c for test and get this error too.

RE: Create DLL file in ADAMS

(OP)
Adams write that files compiled with Intel parallel xe 2019 update 4, this software have Fortran compiler and Visual Studio 2017 for c++ compiler, but now Visual Studio 2017 and this intel can't be integrate together, but it's no matter which version we used, just they must can be integrate. To fix problem, I installed Intel OneAPI 2023.1 and Visual Studio 2022 17.5.6 and set the environment variables.
However, this led to a new error:

To fix this error, Found a library from my Visual Studio directory that was missing in the <install_dir>\Adams\<version>\win64 directory and copy it.
Repeated the same process for other libraries that were causing similar errors, finding them from either Visual Studio or Intel OneAPI directories.
Also one of library kernel32.lib I find from C:\Program Files (x86)\Windows Kits\10\Lib\<version>\um\x64

I hope this solution can also solve the problem of others in creating DLL file.

But when i used other library such as math.h or stdio.h in my code, i got this error:


I copied math.h library to current directory of creating dll file, like slv_c_utils.h, when I delete slv_c_utils.h library also get this error too, but in math.h and other libraries don't solved problem. my VS code can recognize libraries and don't have any problem, I try add libraries to environment variables. but problem don't solved.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login



News


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close