×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Contact Tool not producing initial results

Contact Tool not producing initial results

Contact Tool not producing initial results

(OP)
Hello,
I am relatively new to contact elements, I work in Workbench 16.
I am trying to model a contact and have some issues with it, so I decided to try the Contact tool. However, it does not produce any results when I run "Initial Information", and the error messages are :"The mesh generation was not successful" and "The requested meshing operations failed".

I cannot find enough tutorials that explain how Contact Tool is supposed to work, and I have looked into sharcnet: https://www.sharcnet.ca/Software/Ansys/17.0/en-us/...

Can anyone please explain the requirements for running a contact tool? Is it only for non-linear contacts? Am I supposed to have meshed my model first? Will it show me problems with the contact elements (eg wrong normals)?

Many thanks for your help.

RE: Contact Tool not producing initial results

As it says, mesh generation was not succesful. Contact tool works
also for linear (bonded, no separation) contacts.

RE: Contact Tool not producing initial results

(OP)
L_K, thank you.
Does that mean I should mesh it first before using Contact tool? I have imported my meshing methods and sizing, and when I try to mesh it "separately" - without contact took, it meshes well.

RE: Contact Tool not producing initial results

Never used the tool for post processing only for looking on things like contact status and pressure when post processing.

What I would recommend in order to find out what is going on is the following:

Set all contacts to bonded, and run without geometrical nonlinear behaviour (no large deflections).

If that works then add large deflections, if that works also, then it is a sign that it is the contacts (assuming here you do not have material nonlinear behaviour also).

For more information on how to troubleshoot contacts see: Link & Link & Link
(One thing that often helps convergence (contact related) is to reduce the contact stiffness, from 1 for nonlinear contacts say to 0.01, and perhaps also use update to calculate a new stiffness if needed be)

In any way it is a good idea that you can mesh otherwise nothing will run (not sure if that is the case here, but the tool mentions it).

Hope this helps.

RE: Contact Tool not producing initial results

I have seen some odd behaviour related to the use of contact tool (in the tree under "Connections") before.
If you are able to generate mesh, but the tool is giving error message, first try to delete it and create a new one.

RE: Contact Tool not producing initial results

(OP)
@ Erik Panos Kostson , thank you for your input.

I am already only doing linear analysis with bonded contacts, as I am still figuring out how they work.
I meshed the model. Due to its geometry, I have some rather small elements and some larger ones in the connected bodies.
I want to run Contact Tool because when I try to run the solution, I get the message "The normal of target element A is not consistent with the normal of target element B in real set X. Please use the ENORM command to correct it." - So I want to find the real sets for the contacts from the contact tool, but the fact that it doesn't run make me suspect there are more things wrong with the model.
I tried to run the Contact Tool after meshing the model, but I got absolutely no solution, not even an error message.

It is a possibility that the differences in element size in the mesh create problems with the contacts as well.

RE: Contact Tool not producing initial results

Try first to deactivate all contacts, and apply appropriate restraints so it is not singular and solve.

At least then we know that the model is ok.

Then activate them one by one (contacts), and see when it fails.
(In the error log file it should tell you a bit more information.)

Once we know that, we can look at the geometry and mesh there to see why it gives this error.

If you can and are allowed to send part of the problematic geometry then I can have a look for you to see if I can spot something (normal directions on faces,..).
This is something that could easily happen with shell elements, where the face normal needs to be consistent (in Strand7 one can flip face normals). There is a good blog on how to realign face normals in ANSYS:Link & Link

A workaround also could be to use multibody parts, so you get a compatible mesh between parts (welded), rather than having bonded contacts.

RE: Contact Tool not producing initial results

(OP)
@Erik Panos Kostson, thank you so much for your input!
I did run with no contacts and it solved fine (rubbish deformation, of course). The first contact pair I tried to activate failed in the same way - element normals. I guess that's were the problem is, although I am using exclusively solid elements, because that's what I need for my solution.

I guess I'll have to figure out how to rearrange the normals and hope it solves.

Many thanks for your help, I greatly appreciate it.

RE: Contact Tool not producing initial results

No worries, I have not done much.

If it is solid elements the normal should be well defined for a volume part (I do not think you can flip normals in volume parts, only on surfaces; in Strand7 you can, but that is because everything is made of surfaces, and there is no volume topology).

Try to simplify the meshing process, do not use any additional options (say sizing or method), just mesh simple without extras and avoid using defeaturing (set it to NO) in the mesh. Try also to go down in global mesh size to capture the geometry better without defeaturing, and that should hopefully work. Of course if you get too many elements like that, it might take long to run, but at least we will know that it is the meshing that causes this (then one can add things to improve the mesh, and trying keeping the numbers down).

RE: Contact Tool not producing initial results

Hi,

You can identify which real set is not working (the error of contact normals) by looking at the "solution information" and browsing through the information.

As Erik rightly pointed that for solids the normals are well defined and you should not see this error for solids. One thing you may check is that the contact and target faces are the correct ones which you want i.e. they are the desired surfaces you want as contact-target pair.

May be you can attach a snapshot of when you select the problematic contact-target which causes this error. So when you go to connections and you know which contact is it which is causing the problem - just click on it. It will show the contact surface on the top right corner of the screen and target surface at the bottom right corner.

Thanks,
Shiraz

Shiraz
Sr. Engineer

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!


Resources

White Paper – Your Construction ERP RFP Checklist
Selecting business software for a medium to enterprise-sized construction concern is extremely challenging in large part because most enterprise resource planning (ERP) suites originated in the world of repetitive manufacturing and are therefore a poor fit for a project and asset-centric business. However, midsize to large contractors need the predictable, auditable processes that ERP delivers. Download Now

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close