Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


ControlLogix 1769-L30ER to RSlogix500 ethernet issue

ControlLogix 1769-L30ER to RSlogix500 ethernet issue

ControlLogix 1769-L30ER to RSlogix500 ethernet issue

In RSlogix5000, under the communications tab, who active, I see the IP address of the PLC showing (Im guessing) default of, but as an unknown device. I've set the the address of the PC to static, giving it an address of, mask of, and gateway of

In the who active, it shows the computer with the given address, but it can't link to the PLC. I've tried straight and cross over cables.

I've also tried the USB interface but it cant find the drivers....and searching doesn't seem to locate anything either.

This is running XP on the PC, so under the hardware manager, it can find the PLC and identifies it (so its enumerating) but not indication of what driver its looking for.

Has to be something simple...im sure.

RE: ControlLogix 1769-L30ER to RSlogix500 ethernet issue

Well, of course right after I posted I found some info...

used the BootP to make sure I had the IP set correctly.

Then finally found a dialog box that said...cant talk to it because you need a firmware update. Well of course I do...

It updates the firmware, or at least reports its doing it.

So it now tells me that it cannot communicate due to the firmware version and the offline program are not compatible.

This is a brand new RSlogix release 20.11
The firmware is updated to 21.11 and the offline program says its 20.xx

So whats next? Options say to upgrade the firmware or modify the project revision, but no choices for the project revision other than 20 are allowed.

RE: ControlLogix 1769-L30ER to RSlogix500 ethernet issue

two options: load firmware 20.11 into PLC CPU, OR, update RS5000 to include firmware V21.11 then change the project CPU firmware to 21.11. the versions between CPU and project in RS5000 have to match or you cant go online.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close