×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Material Model No Longer Behaving Correctly? (HELP)

Material Model No Longer Behaving Correctly? (HELP)

Material Model No Longer Behaving Correctly? (HELP)

(OP)
Trying to run a simulation in explicit dynamics and everything was going fine, ran a nice simulation of a ceramic armor plate of Alumina and UHMWPE. Then I discovered that I entered a value into the Alumina incorrectly which is why the entire ceramic was failing at impact. Fixed that, ran it again only to be graced by ANSYS with my perfect UHMWPE model having a stroke every. single. time. I try to run it. Below is a screenshot of the original with the correct behaving UHMWPE.

Notice how elastic it is? That is accurate. Below is the new simulation results.

Notice how the UHMWPE becomes a complete anomaly? It acts rigidly, random failure all throughout the cross section and on the back surface. Yet the material property for UHMWPE NEVER changed. Below are the two material properties I have set up.


The original error was I set the Alumina Hydrodynamic tensile limit to the negative power instead of to the positive power. This resulted in a super weak material that broke immediately on impact. The change has resulted in a more accurate simulation of the Alumina material. But now the UHMWPE is throwing a tantrum. I have the connection between the tile and UHMWPE set to frictionless to try to resolve the error (instead of bonded like it was before), no luck. I also added the sides of the tile as fixed support as well, no luck either. I did lower the mesh size of the Alumina, but that shouldn't be effecting things (3e-4 to 4.2e-4) in the UHMWPE.

Any ideas on why this software refuses to behave and what I can do to fix this? I am already behind over 3 days now because of this, each simulation takes 8+ hours to reach halfway penetration. I am desperate to get this to work correctly, so any help is greatly appreciated!

RE: Material Model No Longer Behaving Correctly? (HELP)

I have not used Autodyn or composite modelling, but still I will put forth this paper which may be useful- "Ballistic impact performance of ultra-high molecular weight polyethylene (UHMWPE) composite armor."

The faces are glued together using add frozen option in geometric modelling of the alumina plate and UHMWPE plate to maintain mesh continuity and to maintain material behavior continuity, equation with Lagrange multiplier is enforced at the interface.

If you are facing difficulties in the analysis which are beyond your control, I advise you to contact Ansys support since this is highly specialized subject for which you may get limited help outside like this forum.

RE: Material Model No Longer Behaving Correctly? (HELP)

(OP)

Quote (NRP99)

Thanks for the reply! That paper you posted is one of the multiples I used to construct this around. Although I'm not sure what you mean by "The faces are glued together using add frozen option in geometric modelling of the alumina plate and UHMWPE plate to maintain mesh continuity and to maintain material behavior continuity, equation with Lagrange multiplier is enforced at the interface." The way I have been taught to handle multiple pieces in contact is by using a contact body interaction in Setup. For this one, the contact between the two is an epoxy so I use BONDED and set the stress limits. I mesh the two pieces independently, using a finer mesh on the Alumina and a coarse mesh for UHMWPE since it has no need to being fine. The really odd thing about the simulation the UHMWPE where the bullet is almost looks like it is trying to fail from plugging, which hypothetically is possible but real world simulation shows isn't really the case. Further evidence showing the simulation is off is how the vertical and horizontal surrounding elements fail and form a really weird looking cube region.

I did try to contact ANSYS support, I've had an open ticket since the 28th and have yet to hear back, albeit that was for my software behaving different than the software when used at my university. I left a message, but I doubt they'll get back to me, they have the worst customer service I have ever seen...

RE: Material Model No Longer Behaving Correctly? (HELP)

To be precise this is what the paper says.

Quote (Ballistic impact performance of ultra-high molecular weight polyethylene (UHMWPE) composite armor)

The composite bi-plates of UHMWPE/ alumina (UHMWPE as a bulk polymer) and Kevlar/epoxy-alumina are geometrically modeled in such a way that the back face of one is in contact with the front face of the other, and they are glued to each other by add frozen option in ANSYS workbench. This glue operation will facilitate the elemental connectivity between the material interfaces. For a multi-layered composite, the tensile stress is generated at the interface of the composites, which tries to separate the two connected layers. Therefore, to maintain the continuity at the interface of the layers, equation (10) must be satisfied. Lagrange multiplier (equation 11) has been introduced to impose equation (10)

My guess is the contact is enforced with Lagrange multiplier equation.

RE: Material Model No Longer Behaving Correctly? (HELP)

(OP)

Quote (NRP99)


Ran the simulation a couple more times trying different things. Ran it with a .005" gap between the armor layers, still resulted in errors. I read the manual on modeling composites in ANSYS and my values are correctly inputted according to the manual. Ran another one with only UHMWPE and this is where it gets interesting.

It is doing the same bad behavior now. Also, I clipped the error message that I am greeted to every time I open up my files. It says UHMWPE is removed but doesn't elaborate on why. Also, notice the date, this was on the 6th the message appeared. Back on that day I was trying to get a accurate model of UHMWPE inserted. The correct simulation ran when that message was present. I don't know if it is still doing this or not; when I initiate a solve, it does say UHMWPE is successfully loaded in. Not sure what to do here, could the save file be corrupted causing this loop? Deleting UHMWPE material and re-creating it hasn't fixed it either.

RE: Material Model No Longer Behaving Correctly? (HELP)

This warning might be due to deleted material property or due to changed geometry and the since the material is not assigned Ansys is assigning default material to the updated geometry. To avoid this just remove default material - structural steel and keep the materials which you need. Other option in mechanical - File=>options=>Geometry=>Assign default material to new bodies on update=> No. By default its No. But check if its changed to yes. If above setting is no and the geometry update contains new body without any material assignment, the body becomes underdefined (with ? mark) and you need to specify the material.

May be you have solved with the wrong material when that message was displayed since the material was changed to default. This is my guess though. For correctly applying material properties do not keep the materials which you don't need in engineering data.

Another thing be extra critical of your simulation. Sometimes there are simple mistakes like missing decimal place, input of wrong numbers, using wrong units, assigning different material property altogether, making mistakes in choosing the correct options, setting the wrong options. These things get overlooked as you spend more time in simulation since you get "feel" of everything is correct. Check each parameters carefully.

RE: Material Model No Longer Behaving Correctly? (HELP)

(OP)

Quote (NRP99)


Thanks for the information on how to stop default material assigning!

I believe you are correct in this, a different material setting was used. I discovered that whenever I change material settings in engineering data it doesn't refresh if Mechanical is open. I had Mechanical open while inputting different values and trying to run it. So sadly, I have no clue what material properties were used in the good simulation. I ran a ton of quick coarse simulations of a ball hitting a UHMWPE plate trying the different values journals used and none behave the same way as the good simulation did. The data from that save file is long gone too from running multiple simulations and it corrupted itself yesterday. Really is a shame that ANSYS operates in the most archaic way (seriously, why does it not update the material property when I change it...), but thanks for the help! Hopefully I can figure out the model I used to get those results somehow.

RE: Material Model No Longer Behaving Correctly? (HELP)

(OP)
So, to wrap this thread up, the problem was Mechanical doesn't update material changes without exiting and reading the upstream data again whenever the material is changed. This caused me to have the wrong material data in engineering data than what the model had used, so when I ran another simulation of it, the model was different and it seemingly was acting different from the ceramic data fix.

For modeling the UHMWPE, I found using the Polynomial EOS, Linear Fracture Criterion, Crack Flow Softening, Principal Stress Failure, and Multilinear Isotropic/Kinematic Hardening gives the best results. Still debating which Multilinear model is correct, the attached video uses Isotropic and is more elastic than when ran with Kinematic. Orthrotopic modeling seems to only be good for more complex modeling of the fibers rather than using it as a block or layers. It tended to have the material rupture along one axis and also eroded projectile material (copper)which UHMWPE isn't meant to do.

RE: Material Model No Longer Behaving Correctly? (HELP)

You can update/refresh the materials after doing changes in material parameters either in mechanical=>model=>RMB=>refresh materials or in project window=>RMB on model=>update, when the Ansys mechanical window is open.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login



News


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close