×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Isight doesnt change the outputs during the optimization

Isight doesnt change the outputs during the optimization

Isight doesnt change the outputs during the optimization

(OP)
I am running a topology optimization of some pins which are used to reinforce a single lap joint.
In isight, I am using a very simple workflow that consists in an optimization module, followed by a script and then by an abaqus component.



The script ensures that the pins built on one piece coincide with the geometry of the hole that is cretated in the other piece (i think this script works just fine).

The abaqus component performs the "lap shear test" of the joint and extracts data of force vs displacement (history outputs of each node in a determined area) of the test. Within abaqus in isight, I prepared a script which calculates from the "hystory outputs" of abaqus, the maximum force that the joint withstands, which is what i want to maximize with the optimization. (I think this part also works fine, because I have tried changing the pins by hand and running the script in abaqus, and i get the results that i should).

The problem when running Isight, is that the first loop of optimization runs well, and gives me the desired output of the maximum force. However, when the second, third, fourth, etc. loops are finished, Isight gives me exactly the same output for all of them, the same result of "maximum force".

What do you think I am doing wrong???

I thought maybe that the .odb file generated after each loop is for some reason not being read by isight during the optimization, but i dont know how to check if this is the issue...

Any suggestions would be very much appreciated :(

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login


Resources

Low-Volume Rapid Injection Molding With 3D Printed Molds
Learn methods and guidelines for using stereolithography (SLA) 3D printed molds in the injection molding process to lower costs and lead time. Discover how this hybrid manufacturing process enables on-demand mold fabrication to quickly produce small batches of thermoplastic parts. Download Now
Design for Additive Manufacturing (DfAM)
Examine how the principles of DfAM upend many of the long-standing rules around manufacturability - allowing engineers and designers to place a part’s function at the center of their design considerations. Download Now
Taking Control of Engineering Documents
This ebook covers tips for creating and managing workflows, security best practices and protection of intellectual property, Cloud vs. on-premise software solutions, CAD file management, compliance, and more. Download Now

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close