×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

NX 1847, Can't delete attribute & roll back to "No Value" status
2

NX 1847, Can't delete attribute & roll back to "No Value" status

NX 1847, Can't delete attribute & roll back to "No Value" status

2
(OP)
Ran across this using PLIST_IGNORE_SUBASSEMBLY.

I would traditionally use the following to show or hide a part in the parts list.
1 = Hide
No Value = Show

But now, once you place a value in an attribute, you can't roll it back to No Value.
Even a no entry puts you parts in a Hide status.

You now need to use, in small case
"on" = Show
"off" = Hide

Dave
Automotive Tooling / Aircraft Tooling / Ground Support Structures

NX11, Win 10 Pro

RE: NX 1847, Can't delete attribute & roll back to "No Value" status

That is interesting, I've had this problem in the initial release of 12 but wrote a grip to delete it since manual manipulation would not unset it, at times. Grip because it was four lines of easy code vs a journal.

I will have to try this next time it happens, thanks.

NX 12.0.1.7 Windows 10

RE: NX 1847, Can't delete attribute & roll back to "No Value" status

Hmz I got the same thing last week.... I had to remove and add a part to fis it....

Strange things are happening.....

Lars
NX native (NX13 or NX1847)
Solid Edge ST10
Inventor
Solidworks

RE: NX 1847, Can't delete attribute & roll back to "No Value" status

in nx12 i have resolve this issue
with this workaround : delete the attributre "PLIST_IGNORE_SUBASSEMBLY
from the attribute bulk editor.
to me return the "NO VALUE" field.
Let me know if this work for you.

NX 7.5 64bit
NX 9.0.3.4 MP4 64bit
NX 10.0.3.5 MP3 64bit

www.studiotreccani.com

RE: NX 1847, Can't delete attribute & roll back to "No Value" status

Yes, it works with bulk editor on NX1847 too.

Suresh
www.technisites.com.au

RE: NX 1847, Can't delete attribute & roll back to "No Value" status

(OP)
Yes you can do it in the bulk editor... good find.

Right Click on the field, select "Clear Contents"
Works in V11 & V1847.

Dave
Automotive Tooling / Aircraft Tooling / Ground Support Structures

NX11, Win 10 Pro

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login


Resources

White Paper - Considerations for choosing a 3D printing technology
The adoption of 3D printing into major companies’ product development life cycles is a testament to the technology’s incredible benefits to consumers, designers, engineers and manufacturers. While traditional production methods have limitations in manufacturability, 3D printing provides unparalleled design freedom due to the additive method of building parts layer by layer. Download Now

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close