×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

PMI visibility in drafting

PMI visibility in drafting

PMI visibility in drafting

(OP)
Hi,

Problem description:

Unable to show PMI made from sketch in the drafting module in parent item.
Other PMI made manualy are shown (PMI Assembly Filters).

In master model (drafting module), PMI made from sketch and PMI made manualy are visible.

This problem occurs only in parent item. In master model everything is ok.

RE: PMI visibility in drafting

Check if the PMI information is also in the ref set MODEL

Ronald van den Broek
Senior Application Engineer
Winterthur Gas & Diesel Ltd
NX9 / TC10.1.2

Building new PLM environment from Scratch using NX11 / TC11

RE: PMI visibility in drafting

Hi Ronald,

I don't understand you answer because it was not possible to add PMI on the Ref Set Model. I have opened a call on GTAC for that.

I use the following process:

Use Reference Set "Entire Part"
then
the sketch should be visible in the master model !!!

Regards
Didier Psaltopoulos
http://www.psi-cad.fr

RE: PMI visibility in drafting

PMI is view dependent. As such, it would not show up in reference sets.

"Know the rules well, so you can break them effectively."
-Dalai Lama XIV

RE: PMI visibility in drafting

(OP)
Thank you all,

"reference set" solved the problem.

RE: PMI visibility in drafting

Hi Buyo,

You should say reference set "entire part" solved the problem

Ins't it ?

Regards
Didier Psaltopoulos
http://www.psi-cad.fr

RE: PMI visibility in drafting

(OP)
By default is "entire part" but the PMI from sketch was not active.
You have to select them in the "entire part" reference set.
That will do the job.

RE: PMI visibility in drafting

Hi Buyo,

Thanks in advance to post an image of your setting

Regards
Didier Psaltopoulos
http://www.psi-cad.fr

RE: PMI visibility in drafting

Hi,

OK, but your example is so simple

In fact, you don't add only PMI to your ref set because they are not selectable. You are obliged to select the whole sketch

I found a trick to blank the sketch in drafting and what about you ?

Regards
Didier Psaltopoulos
http://www.psi-cad.fr

RE: PMI visibility in drafting

Because you are talking about ref set I assume you work with master model. Then PMI is in model part and you need to show PMI in DWG model.
Firs make sure your component is fully loaded (If you open drawing file directly. If you open model and then drawing it will be loaded)
Then when you place view, go to view settings and find PMI tab. In PMI tab click on drop down menu and select From Model View. This should be enough to see PMI that you get in that view without need to use ref.sets.

_____________________________
Enjoy your work and have fun!

RE: PMI visibility in drafting

Hi Ivan,

I don't agree with you

I know this process, but I you don't use Entire Part, you will have the following message:


Regards
Didier Psaltopoulos
http://www.psi-cad.fr

RE: PMI visibility in drafting

Then you have to set OBJECTS that PMI is linked to to model ref set. PMI is not part of ref set, but they are connected to model so if you removed parts of model form Model ref set, that is why you can't see PMI. PMI works without ref.set if all objects that have PMI are in model ref set.

_____________________________
Enjoy your work and have fun!

RE: PMI visibility in drafting

Hi Ivan,

Could you send a screenshot to explain where you do this settings ?

thanks in advance

Regards
Didier Psaltopoulos
http://www.psi-cad.fr

RE: PMI visibility in drafting

If you have model with all objects with PMI in model reference set

Then drawing looks like this


But if you remove one solid body from model reference set




Then you get that error message (either on update or in your case on view placeing)


So go to reference sets in your model, and make sure that all objects that have PMI conneted to them are in model reference set.
After thinking a little, I think that you have sketch that is stand alone, so it does not make body, but it have PMI connected to it (bodies are by default set in Model refeernce set, but sketches are not). You should add that sketch to Model reference set, so you do not have to use Entire Part.

_____________________________
Enjoy your work and have fun!

RE: PMI visibility in drafting

Hi Ivan,

You are right, I am taking about standalone sketch. And in this case I know the process and I should use ref set or entire part.

But I am obliged to hide the sketch in the Master model to avoid see it in the drafting :( Other idea ?

Regards
Didier Psaltopoulos
http://www.psi-cad.fr

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!


Resources


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close