×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

RISA 3D - No Compressive Capacity

RISA 3D - No Compressive Capacity

RISA 3D - No Compressive Capacity

(OP)
Hi,

I am trying to run and design a steel model in RISA 3D. My reactions are correct in the model. However, when I try to design for the members, my unity check is 9.999. I realized that this is due to my fiPnc is essentially zero, making my unity check approach infinity. I have checked all my members, and none are set as tension-only. My section properties also seem to be correct. Anyone have any other ideas about what is causing this?

Thanks.

RE: RISA 3D - No Compressive Capacity

I had an issue previously where it was a I was checking a custom shape (PEMB reinforcement) and the thickness of some of the member pieces were making it a class 4 section. This was causing me to have zero compressive capacity.

RE: RISA 3D - No Compressive Capacity

Have you checked your unbraced lengths? Could accidentally be set to something extremely large.

If you post your model someone can probably take a look.

RE: RISA 3D - No Compressive Capacity

There should be something in the member detail report to suggest why the member code check is so large. Whether the member is reported as "slender" (which means local buckling will come into play), or whether the KL/r value is reported as very large is impossible to tell without seeing the model.

Also, knowing the version of the program could help as well. This can be determined by going to help - About RISA-3D from the Main Menu toolbar. I recall some years ago one version of the program would always report very large axial code checks for a certain type of member. I'd have to go back through the release notes to get the details about what was happening and why....knowing what version you are running would help narrow it down.

RE: RISA 3D - No Compressive Capacity

(OP)
I am running RISA v 11.0. Attached is a a copy of the file.

RE: RISA 3D - No Compressive Capacity

(OP)
RISA 11.0.2 (64bit) to be exact.

RE: RISA 3D - No Compressive Capacity

So, I'm not getting that behavior with the 11.0.2 version that I'm running on my system. And, I don't see anything obvious in the release notes about what could have caused this.

Reviewing the release notes around that release, I've seen some similar items related to foreign codes or other shape types. But, I don't see anything for wide flange or channels done to the AISC codes. So, nothing that would apply to your model.

That was right around the time we added "Ltorque" to the program. So, you might try playing with the Ltorque value to see if that changes things at all. Also, you might try playing with the Tools - Preferences / Application Settings. On the solution tab of this dialog there are check boxes that allow KL/r>200 and which allow code checks if you don't include PDelta analysis.

Note:
When I run this in the current version (RISA-3D v14.0.1), I get normal looking code checks ranging between 0.150 and 1.26. With normal looking Phi*Pn capacities. The same as what I get when I run it in 11.0.2.

RE: RISA 3D - No Compressive Capacity

(OP)
Thanks JoshPlum. Unfortunately, changing LTorque does not seem to be doing anything for the code checks. In my model, I also had already turned off PDelta analysis and the requirement for slenderness ratio. Also, I am not able to rotate my members about their x-axis. Not sure if that problem is indicative of a larger issue with my copy of RISA.

RE: RISA 3D - No Compressive Capacity

What happens when you try to rotate your members about the x axis? I assume we're talking about the channel member, right?

RE: RISA 3D - No Compressive Capacity

Okay, there are a couple of possibilities here. A corruption to a "default" file or database being the most logical one. Two things to try:
1) After shutting down the program, go to the directory where RISA-3D is loaded and move all the files with the extension *.DEF into a backup directory. These are the default settings for when a new file gets created, when a new window is opened and such. If these settings get corrupted, they can corrupt the entire memory state of the program. Which can lead to odd behavior (like not being able to rotate members). It doesn't often affect code checks, but when it does, the effects would be usually garbage results. Like values that are not numbers and such. It is possible that certain aspects of the program could interpret garbage results as a 9.99 code check.

2) Same basic concept as above, but with a file called repnames.fil. This is a database that stores user defined reports and such. At some point in the past (I thought this was before 11.0, but who knows) there was a bug that could cause this database to be corrupted. Either delete it or move it to a backup directory.

After doing those two things above you should try to re-run the file to see if you get better behavior.

If all else fails, try running it on a different computer. Or, try uninstalling and reinstalling into a new directory. The reason why I say a new directory is because the uninstall will not wipe out a lot of the databases that may be used by other RISA programs.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login


Resources

White Paper - Implementing a Multi-Domain System
IoT systems are multi-domain designs that often require AMS, Digital, RF, photonics and MEMS elements within the system. Tanner EDA provides an integrated, top-down design flow for IoT design that supports all these design domains. Learn more about key solutions that the Tanner design flow offers for successful IoT system design and verification. Download Now

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close