Contact US

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Error inserting reference image Drafsight

Error inserting reference image Drafsight

Error inserting reference image Drafsight

Hi Guys,

I use Draftsight for quite a while now and it always worked completely fine.
Until I installed Windows 10 Last week. Since then I can't see any reference image anymore in either my model or my drawings.
When I insert the image, it does preview though...

Tried different images, different Draftsight files, also older files have the same problem
Deleted and installed Drafsight again, didn't work.

Could somebody please help me? Much appreciated!

Please see screenshot of model attached

RE: Error inserting reference image Drafsight

Can anyone please help me on this? Still haven't been able to fix the problem

RE: Error inserting reference image Drafsight

I've not had this problem. I know Windows 10 is a little buggy though!

Just scratching my head....

When you look at the properties of the referenced image, I take it that the 'show image' box says 'yes', and that the path to the file hasn't been changed by the windows install?

I'll keep thinking....


RE: Error inserting reference image Drafsight

Type 'image' hit enter, see if there are any clues in the References Palette.

RE: Error inserting reference image Drafsight

Thanks Simon

I checked the all the properties and it should be just fine. Also the path to the file is correct and even the linking the image to the file again doesn't help.

One weird thing though... As I said, the image previews correctly and sometimes when I'm zooming in our out in the model I can see a little blink of the image and then it is gone again. Also, when I create PDF's, the image does shows up in the PDF.

This is all for existing files where I already put in a reference image before all the problems came up after installing Windows 10.

Draftsight just came up with something else:
When I wanted to add a reference image into a new file, Draftsight let me select the particular image from my files, I clicked "open" and then Draftsight freezed and eventually crashed. I tried this with both jpg and png images and in different files. All the same problem. Even when inserting a reference image into an existing file.

Any ideas?



RE: Error inserting reference image Drafsight

Type HIDEVIEW and hit enter. Does that do anything?

RE: Error inserting reference image Drafsight

That looks like something to do with the scale of it.

I don't seem to be able to reproduce it.

RE: Error inserting reference image Drafsight

I can confirm this problem on windows 10, fully updated with the latest version of draftsight.

I'm sure there must be a third factor causing this problem or else everyone with windows 10 and draftsight would have it.

Any ideas what other factor may be causing this?

RE: Error inserting reference image Drafsight


I tried it as well on another laptop with Windows 10 on it (also 64 bits). And it worked fine!
What can it be? Compatibility problems?

RE: Error inserting reference image Drafsight

Guys, found it...

Just be sure you've updated your graphics drivers to the latest version.
You could use this tool to make it easy: http://www.intel.com/p/en_US/support/detect

It's as easy as that :)


RE: Error inserting reference image Drafsight

Good find Jordy.

I updated mine even though I didn't have that graphic problem, the drivers I had were quite old. (Good old Windows doing it for you... or not!)

RE: Error inserting reference image Drafsight

Hi PVJord

I saw your musing earlier on jpeg insertions in DraftSight – as I am having the same prob – the inserted jpegs don’t appear or ‘shuts off’ into a blur when u try and trace over it.

I down loaded the utility u mentioned and it states I already have the latest drivers (for my new windows 10) ~ perhaps it was glitchy when first installed and reloading it might not hurt………..the driver no. is;

Just wondering what driver no. u downloaded to fix it.

The other option might be to download an older version – but that sounds a bit regressive…

I’m on the free version; DraftSight ‘2015 x64’ (who knows, perhaps this function is turned off the freebe..)

RE: Error inserting reference image Drafsight

Hello - I've got this problem to. Did You finally resolved the problem?? I've tried older version of DS and it didn't work...

RE: Error inserting reference image Drafsight

I have the same issue. Subscribing to the thread.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close