×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

ADAMS/CAR unknown error

ADAMS/CAR unknown error

ADAMS/CAR unknown error

(OP)
Just recently I have started using Adams/CAR for double wishbone suspension kinematic and element force analysis. Before I used to build my wire frame rigid models using Adams/View which worked great as far as the simulation is concerned but it lacked the prebuild functions for example setting/measurement of Camber, Toe etc. that Adams/Car is specialized for. I have went thru most of Adams/CAR tutorials dealing mostly with template usage, which should be fine for my case. This was my workflow for front suspension analysis:
1. created a new assembly with TR_front_suspension.sub as the only subsystem (i will include steering subsystems later, for now only bump-rebound characteristics)
2. modified hard points to suite my design. My coordinate system is in the intersection of ground plane/fvsa plane/longitudinal symmetry plane. x-axis is pointing forward y-axis to the left which is opposite in Adams so i just changed the sign in these two directions. Also I set every coordinate of testrig to 0 I
3. I modified coil over properties to linear spring (i have only theoretical spring calculations) and some minimal damping (at this point i am not concerned with velocity-damping response)
4. Edited tire data (unloaded radius and tire stiffness) and vehicle parameters.
5. Suspension analysis: parallel travel 80mm bump -60mm rebound

With default solver settings I got this message:
=================================================================
Adams/Tire
Version Adams 2013.2
=================================================================

acar_2013.1.0/ac_scc_init

Reading ARRAY parameters using the
ADAMS/Car array statement definitions.

acar_2013.1.0/ac_scc_init

Checking ARRAY parameters...

-------------------------------------------------------------------------------
| Model Title |
|=============================================================================|
| |
| Adams/Car Assembly (Adams 2013.2) |
| |
-------------------------------------------------------------------------------

command: preferences/solver=CXX
command: preferences/list,status=on
PREFERENCES:
SIMFAIL = NOSTOPCF
Contact Geometry Library = Default
Contact Faceting Tolerance = 1
Thread Count = 1
Library Search Path = Not Set
Status Message = On
Solverbias = CXX (C++ Solver)

command: control/ routine=acarSDM::con950, function=user(950,29,31,1,2,18,20,1,3,2,3,28,30,2,3,28,30,1,1)


Begin Static Solution


STATICS: Original static solver will be used with the Sparse linear solver.


---- START: WARNING ----
Actuator reached upper force limit

---- END: WARNING ----


---- START: ERROR ----

Static equilibrium analysis has not been successful.
The maximum number of iterations 25, has been reached.
For the last attempted iteration:
The equation with the largest error was model.TR_Front_Suspension.ges_subframe Comp = 8 Error = 200849082.519939
The variable receiving the largest increment was model.testrig.jolfix_table_fixed Comp = 4 Delta = 161973045.741471.

---- END: ERROR ----
Static Solution failed to converge

End Static Solution

Simulation failed



---- START: ERROR ----
Initial Static Sim. Not Successful
ID = 0


---- END: ERROR ----


---- START: ERROR ----

Adams/Solver run terminating due to STOP requested by user.


---- END: ERROR ----

Termination status=-995

Terminating Adams/Car usersubs...


Finished -----
Elapsed time = 0.31s, CPU time = 0.30s, 96.08%
Analysis failed!
Please check the error messages to determine the cause.
-----------------------------------------------------------------------------------------------------------------------------------------------------------

Then I increased the MaxIt for static solver from 25 to 50. It convergences to a result but it's nonsense (see attached 1.jpeg) This is the lower part of the message:

------------------------------------------------------------------------------------------------------------------------------------------------------------
****** Performing Quasi-Static Simulation ******

---- START: WARNING ----

The Reconcile Acceleration-Force has detected a singular Jacobian matrix.
This problem may be caused by:
(a) A constraint equations that became almost redundant, e.g., the model
is at a singular configuration or at a bifurcation point.
(b) A massless PARTS in the model.

The Sparse Solver has detected a zero pivot for row 67 (during the symbolic pivot selection).
The corresponding equation is: Part/26 X Force

A minimization algorithm will be used to find a solution on the
projected constraint manifold.

---- END: WARNING ----
Simulation Step Function Cumulative CPU
Time Size Evaluations Steps Taken time
___________ ___________ ___________ ___________ ________
1.00000E+00 0.00000E+00 0 0 0.70
2.00000E+00 1.00000E+00 116 13 0.75
3.00000E+00 1.00000E+00 124 14 0.80
4.00000E+00 1.00000E+00 132 15 0.83
5.00000E+00 1.00000E+00 140 16 0.88
6.00000E+00 1.00000E+00 148 17 0.94
7.00000E+00 1.00000E+00 156 18 0.98
8.00000E+00 1.00000E+00 165 19 1.02
9.00000E+00 1.00000E+00 174 20 1.08

---- START: WARNING ----
Actuator reached upper force limit

---- END: WARNING ----
1.00000E+01 1.00000E+00 209 21 1.22
1.10000E+01 1.00000E+00 228 22 1.30

End Simulation

Simulate status=0

command: !
command: stop

Termination status=0

Terminating Adams/Car usersubs...


Finished -----
Elapsed time = 1.30s, CPU time = 1.30s, 100.07%
Simulation(s) are complete!
Loading analysis results...
Removing analyses of the same name from session...
Loading results done.


--------------------------------------------------------------------------------


Do you know what is wrong with my input data. Any help is much appreciated.

Attachments:
http://files.engineering.com/getfile.aspx?folder=9...
http://files.engineering.com/getfile.aspx?folder=9...
http://files.engineering.com/getfile.aspx?folder=9...




RE: ADAMS/CAR unknown error

(OP)
GregLocock, thank you for the suggestion. I will check if our license includes MSC support. We are using educational licenses, which were hard to acquire in the first place, so I hope for the best... Meanwhile, if someone sees what went wrong, please comment.

RE: ADAMS/CAR unknown error

Otherwise, start from the supplied configuration, which hopefully works. Do your test with that. Then change each parameter to your new value and rerun until you find which mod is breaking the model.

Cheers

Greg Locock


New here? Try reading these, they might help FAQ731-376: Eng-Tips.com Forum Policies http://eng-tips.com/market.cfm?

RE: ADAMS/CAR unknown error

(OP)
I remember doing that in the past and each time it failed after I set the first HardPoint, any HardPoint. My problem regarding the ''Actuator reached upper force limit'' at the start of this tread was resolved by adjusting the spring preload, more precisely lowering it. After that, Adams successfully converged using default solver settings. That's one problem solved. I still get the result where the tie-rod ''breaks'' and the actuator penetrates the tire as seen in one of the attachments above.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!


Resources

White Paper - Effects of AIA Quick Guide to UL 489 or UL 1077
The function of a circuit breaker is to provide overload (thermal) and short-circuit (magnetic) protection to a circuit and its downstream components. A circuit breaker functions like an airbag in a car, protecting circuit components and people by tripping the circuit to interrupt the current flow if it detects a fault condition in the control system. Download Now
White Paper - Guide to Integrate Large-Format Additive
As with any new technology, getting into large-format 3D printing begins with investigation. The first question may be a simple one: what does “large-format” mean? For 3D printers, “large” is a relative term. Many extrusion-based (FFF) 3D printers are referred to as desktop machines, because they fit on table space. Some of these have very respectable build volumes – but when it comes to “large-format,” the machines will need their own dedicated floor space. Large-format 3D printers have significant build volumes and are most often found in professional settings, like manufacturing facilities and R&D centers. Download Now

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close