×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Error when reading model Catia 4.2.2

Error when reading model Catia 4.2.2

Error when reading model Catia 4.2.2

(OP)
Sorry for double post, but subject line was empty..

Hi all,
I'm a newbie around here and decided to drop a question since I'm really running out of options..
At our institute we work with Catia 4.2.2 and so does one of our cooperating institutes. The only (obvious) difference between these two Catia environments is that we don't have the piping module and they do.
Since long we have been battling the following error-message, which occurs when we try reading models at our institute that were made (or modified) in their environment:

*MODEL CANNOT BE READ
*DATA STRUCTURE CREATED WITH A MORE COMPLETE SOFTWARE *CONFIGURATION.                 
*CURRENT SOFTWARE IS INSUFFICIENT TO UNDERSTAND *DATA.                               
*SOME SOFTWARE COMPONENTS ARE *MISSING                                               
*CURRENT LEVEL IS:CATIA SOLUTIONS V4  RELEASE 2.2 FR *4.2.2                           
*CAT_G22_SOLID    CANNOT BE FOUND
===========================================================
*ERROR IN SUBROUTINE : G7MREA   WHEN CALLING SUBROUTINE : *MDMAR           
*ERROR CODE : 218  

*ERROR IN CATGEO/CATMSP *SOFTWARE                             
*ERROR DETECTED BY SUBROUTINE : *MDMAR                                
*CURRENT MODEL NUMBER : 1
*ERROR CODE :   218      SEVERITY : 3
*
*   MODEL CONTAINS ENTITIES WHICH CANNOT BE READ

Could someone give me a lead what might be causing this 'incompatibillity'?

Thanks,

Dennis Ronden, FOM Institute for Plasma Physics

RE: Error when reading model Catia 4.2.2

Hi,

this is may due to the old version of catia, u ve,


saju

RE: Error when reading model Catia 4.2.2

(OP)
Thank you saju, for replying to my thread.
The thing is that both versions of Catia are exactly alike: V4.2.2. The files can be read one-way though. They can read our files, but not the other way around. Another thing is that not ALL the files can't be read; some can. It's just incredibly hard to determine what settings or elements make the difference. The absence of the piping module on our systems shouldn't matter, since piping can be read without the module; the elements only cannot be modified..

Dennis

RE: Error when reading model Catia 4.2.2

Hi Dennis,

I am not clear weather u reading model files directly or trying to read the export file, if u trying to read model file directly this error messeges is common,

So u ve to ask them for export file, which can imported into catia. you right licence is nothing do with models, bcos our customer has abt 20 licences & we r working with 2 licences

saju

RE: Error when reading model Catia 4.2.2

(OP)
Hi Saju,
we've indeed only attempted to read the files directly. If I remember correctly, your suggestion was made before, however. I don't see why this would make any difference and besides, why should there first be made an export file if both the Catia versions are the same? I believed exporting files is only useful between different versions / programs..
Don't get me wrong, I will certainly try to make an export file first, to see if that makes any difference.

Thanks for your input,

Dennis

RE: Error when reading model Catia 4.2.2

U need to export files for an env. to another only if "Project Files" aren't the same and/or they haven't be declared under the same name.

obviously, If you can't read a model done in 422 on a 422 test if the first one isn't a 422 Refresh 1 ! if it is you may make a Catback on your model in the catutil of the first one !

Stan

RE: Error when reading model Catia 4.2.2

You are not running the same package as the other site.
Your version does not recognize piping  because you have not
selected piping as part of your software package.

RE: Error when reading model Catia 4.2.2

(OP)
Thank you for the suggestion CMES, but unfortunately we've already tried to read in certain models in a catia-station at the remote location without the piping license retrieved. This worked fine; the model could be viewed, but no piping elements could be modified. I think this shows the problem is something else.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login


Resources

Low-Volume Rapid Injection Molding With 3D Printed Molds
Learn methods and guidelines for using stereolithography (SLA) 3D printed molds in the injection molding process to lower costs and lead time. Discover how this hybrid manufacturing process enables on-demand mold fabrication to quickly produce small batches of thermoplastic parts. Download Now
Design for Additive Manufacturing (DfAM)
Examine how the principles of DfAM upend many of the long-standing rules around manufacturability - allowing engineers and designers to place a part’s function at the center of their design considerations. Download Now
Taking Control of Engineering Documents
This ebook covers tips for creating and managing workflows, security best practices and protection of intellectual property, Cloud vs. on-premise software solutions, CAD file management, compliance, and more. Download Now

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close