Contact US

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Hide internal thread surface in drawing

Hide internal thread surface in drawing

Hide internal thread surface in drawing


I'm making some drawings in pro engineer starting from 3D part files. I want to hide threaded holes in the drawing. But when i hide the layer with the holes, only the outer diameter is hided, and the included thread surface is still there. How do i hide it?

I also tried with hide/show, but it has the same effect.

Any help would be very appreciated.

Deleting the surface in the part file is not a option, because i need it in another drawing.

Some images:




RE: Hide internal thread surface in drawing

Try implementing the config.pro option
HLR_FOR_QUILTS YES from Tools - Options

Check the following posted by user alibahadir at
hlr_for_quilts in section

Here is the solution for that offered by Ptc
Hidden line removal is known as not working  in X-section views containing quilts which usually come with vendor parts.

In order to enable the HLR settings for X-section views (by the view settings or by the default settings with config.pro option 'hlr_for_quilts' set to YES), there are two requirements:

1. the dtl (drawing config.pro) setup option 'show_quilts_in_total_xsecs' MUST be set to 'yes' (the default is 'no')
2. the cross section MUST be created using the option 'Model & Qlts' for the cross section definition


RE: Hide internal thread surface in drawing

Thank you mjcole for your help.

But this is not what i need. The view is not a section. So i guess that's the reason it doesn't work for me.

The threaded hole is for example M8x1,25 with thread surface included > extra surface with diameter 6,8. When i hide the hole in the drawing, the surface with diameter 8 is hided, but the one with diameter 6.8 not.


RE: Hide internal thread surface in drawing

Put all the surfaces on a layer, and hide that layer in your drawing.


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login


Low-Volume Rapid Injection Molding With 3D Printed Molds
Learn methods and guidelines for using stereolithography (SLA) 3D printed molds in the injection molding process to lower costs and lead time. Discover how this hybrid manufacturing process enables on-demand mold fabrication to quickly produce small batches of thermoplastic parts. Download Now
Design for Additive Manufacturing (DfAM)
Examine how the principles of DfAM upend many of the long-standing rules around manufacturability - allowing engineers and designers to place a part’s function at the center of their design considerations. Download Now
Taking Control of Engineering Documents
This ebook covers tips for creating and managing workflows, security best practices and protection of intellectual property, Cloud vs. on-premise software solutions, CAD file management, compliance, and more. Download Now

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close