×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Runtime error
2

Runtime error

Runtime error

(OP)
When I run Mathcad 13 it gives me a Microsoft Visual C++ runtime Library error.  "Runtime Error!"  "The application has requested the Runtime to terminate in in an unusual way"

I tried uninstalling, cleaning the registry and re-installing.  No help.  

I tried un-installing and reinstalling V12.  No help.

Any ideas?

RE: Runtime error

2
I had similar problems when launching V13. The program would not start. Mathcad's customer service was very helpful. But, I vaugely remember having difficulty finding the contact information: http://support.mathsoft.com/Contact/ The initial response to my email did not solve my problem. So, I called on the telephone (in US) and they were very prompt and helpful. If your error occurs while launching the program, I can look through my old email for the initial response and outline the solution to my problem. But, contacting Mathcad may be your easiest and best option.

RE: Runtime error

(OP)
My problem does indeed happen during launch.  I never get close to a working screen.  If you could dig through your email, it just might get me back to work!!  Thanks for the contacts tip, I'll call them Monday AM.

RE: Runtime error

Here it is:

Symptom: Launching Mathcad yields the error:
Microsoft Visual C++ Runtime Library

Runtime Error!
Program: C:\Program Files\Mathsoft\Mathcad \mathcad.exe

This application has requested the runtime to terminate in an unusual way.

Cause 1: The Mathcad installation is missing the prerequisite called MSXML. You can check this by looking in Add/Remove Programs.
Solution 1: Install the prerequisite by running the file "msxml.msi" located in the "Prereq" folder on the Mathcad CD. Then launch Mathcad again.
Cause 2: The Mathcad local assembly cache is corrupted. NOTE: This is more likely with Mathcad 12 than Mathcad 13.
Solution 2: Go to C:\Documents and Settings\(username)\Local Settings\Application Data\Mathsoft\Mathcad and delete the folder named after your version. It is safe to delete that folder since launching Mathcad will result in the creation of a fresh copy of that folder. Next, launch Mathcad again.
Cause 3: You have Mathcad 12.0 or 12.0a and have Microsoft .NET Framework 2.0 installed. You can check the version number by looking in Add/Remove Programs. Mathcad didn't work with Microsoft .NET Framework 2.0 until Service Release 1 for Mathcad 12.
Solution 3: Install Service Release 1 for Mathcad 12 after downloading it from the Mathcad.com Download Center, http://www.mathcad.com/download/. Then launch Mathcad again.
Cause 4: The Mathcad installation is missing the prerequisite called Microsoft .NET Framework. You can check this by looking in Add/Remove Programs.
Solution 4: Install the prerequisite by running the file "dotnetfx.exe" located in the "Prereq" folder on the Mathcad CD. Then launch Mathcad again

My problem was with the MSXML file. XP's add/remove programs was used to remove two MSXML files. Then the msxml.msi file was installed from Prereq folder on the Mathcad CD. This fixed the problem. Afterwards, Windows update changed the MSXML file and I had to go through the process again. Since then, I review the files that Windows want to update and don't update the MSXML file (don't know if that is the best thing to do but it works for me).

RE: Runtime error

(OP)
.NET is up to ver 3.  I deleted all and then used the Mathcad install.  Also used the Mathcad CD to put in MSXML.  Mathcad now works.  THANKS !!!  

Question:
Is it bad to update the .NET Framework?
Is it bad to keep it at rev 1 when rev 3 is out there?

RE: Runtime error

I am glad things worked for you. I honestly don't even know what .NET Framework is/does. I checked and my computer has 1.0 and 1.1 with a couple "hotfix" listed in Add and Remove Programs.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login



News


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close