×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Cant change parts of dimension standards

Cant change parts of dimension standards

Cant change parts of dimension standards

(OP)
I am trying to customize the arrowheads, dimension lines, etc. for a given standard (ANSI in this case) but the fields are all greyed out. This is under the tools/standards/drafting menu; I checked under tools/options to see if there was some admin lock on altering the drafting standards but didnt find anything. There must be some other menu or something that allows this access. I am using v5 version 10. Thanks.

RE: Cant change parts of dimension standards

You need to start up CATIA in Admin Mode.  You will need to have write access to the directories pointed to by the following Environment Varialbles:

CATReferenceSettingPath
CATCollectionStandard

Then start up catia using the following command:


<installpath>\code\bin\CATSTART.exe -run "CNEXT -admin"

Where <installpath> is the installation path of CATIA.

RE: Cant change parts of dimension standards

(OP)
I tried to start by browsing to this .exe file, but I get the same result-the fields are greyed out.  Im not sure what you mean by having access to the CATReferenceSettingPath etc.  I looked in the catia directories and found the actual .xml file that controls the standard, it will open in my browser, can I modify this file directly?  I would need to know what parameters in the file sync with the changes to the standard in catia.  Anyway, please advise.  Thanks for your help.

RE: Cant change parts of dimension standards

Hi,

Search the CATIA ONLINE DOC. You will find all information about ENVIRONMENT, XML files and which parameter to change.

if there is something you do not understand in the ONLINE DOC let us know, if you have some pb changing your XML file, post your XML we will have a look.

For who are you working to be on R10 ? Should move to R14 or 15.

You might not find all info winthin R10 online doc, check R15 it will help you.

Eric N.
indocti discant et ament meminisse periti

RE: Cant change parts of dimension standards

I would be VERY careful editing the .xml file directly - it's very easy to corrupt (definitely make backups!). Yes, it can be done that way.

By access, I mean that you need write permissions for those directories.

No, you cannot get to admin mode by browsing to the catia bin directory and double-clicking on the executable.  You need to execute CATIA thru a shortcut with that command in it.  The easiest way is to copy your existing CATIA Shortcut, and then edit it to include the -admin option.

RE: Cant change parts of dimension standards

(OP)
Ok. I searched the online documentation and I think I understand things better now.  However, I still am not doing something right.  I created a shortcut with the following path: C:\Program Files\Dassault Systemes\B10\intel_a\code\bin\CATSTART.exe -run "CNEXT -admin"  Once entered as the shortcut target, I select "find target" and it shows me the file (CATSTART.exe), looks good.   Then I click "apply" and the short cut target now says "C:\Program Files\Dassault Systemes\B10\intel_a\code\bin\CNEXT.exe"  -env CATIA.V5R10.B10 -direnv "C:\DOCUME~1\ALLUSE~1\Application Data\DassaultSystemes\CATEnv"   It will run when I use this shortcut but I still cant change the standard.  This is in addition to trying to modify the global environment variables using the "environment editor" tool.  According to the online documentation I need to check/alter two variables.  One of them had a path set (CATDefaultCollectionStandard) the other one did not (CATCollectionStandard).  According to the online documentation I need to create some directory named "standard_1" with the subdirectory "drafting" and set "standard_1" as the path for CATCollectionStandard.  This will supposedly be where my modified standards are stored, but there is nothing in these directories when I create them, do I need to copy the existing xml files into my new directory?  This is obviously confusing to me...sorry my message is so long and incoherent.  Any help is appreciated.
Thanks.

NOTE: here is a clip of the online documentation I was following:

The recommended method for customizing standard files is the following:
    

You need to work in administrator mode. To do this, proceed as follows:  

Set up the CATReferenceSettingPath variable.

Start a V5 session using the -admin option.

For more information, refer to the Managing Environments chapter in the Infrastructure Installation Guide.

Set up the CATCollectionStandard environment variable.

If none of the conditions are respected, a warning message will appear to let you know that you will neither be able to modify nor save the XML file.


Modify the Drafting standards as appropriate.

Use the Save As or the OK button to store your modifications.

To exit, use the Cancel button.

Once the standard files have been customized and saved, they can be used in a V5 session in normal mode

RE: Cant change parts of dimension standards

Sounds like you are doing everything write.  No, the directory can remain empty.  When you edit one of the standards, there is a "Save As" function that will allow you to save the default standards to your custom directory.

When you start CATIA, do you get a pop-up telling you that you are in Admin Mode?  Also, the title bar of CATIA should state that you are in Admin Mode.  

One thing that you might check, I believe that at R10 you needed to be a Windows Administrator in order to get into Admin Mode.  At R14 this is no longer required (it may have occured earlier, but I didn't notice until R14).

RE: Cant change parts of dimension standards

Quote (chev72):

Then I click "apply" and the short cut target now says "C:\Program Files\Dassault Systemes\B10\intel_a\code\bin\CNEXT.exe"  -env CATIA.V5R10.B10 -direnv "C:\DOCUME~1\ALLUSE~1\Application Data\DassaultSystemes\CATEnv"   It will run when I use this shortcut but I still cant change the standard.

Have you tried putting the -admin in the shortcut above?
i.e., "C:\Program Files\Dassault Systemes\B10\intel_a\code\bin\CNEXT.exe" -admin -env CATIA.V5R10.B10 -direnv "C:\DOCUME~1\ALLUSE~1\Application Data\DassaultSystemes\CATEnv"

RE: Cant change parts of dimension standards

(OP)
I think I've almost got it. Changed the shortcut, added the "-admin" and now I get an error saying I need to set the reference settings variable path in my environment.  Im checking it now...it is blank. What do I use as the path for the CATReferenceSettingPath?

Thanks, all your help is greatly appreciated.

RE: Cant change parts of dimension standards

(OP)
SUCCESS!!!!!!!!!!!!!!
I got it to work, just named a folder for the catreferencesettingspath variable to point to and it worked.
Thanks for everyone for your help.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login


Resources

Low-Volume Rapid Injection Molding With 3D Printed Molds
Learn methods and guidelines for using stereolithography (SLA) 3D printed molds in the injection molding process to lower costs and lead time. Discover how this hybrid manufacturing process enables on-demand mold fabrication to quickly produce small batches of thermoplastic parts. Download Now
Design for Additive Manufacturing (DfAM)
Examine how the principles of DfAM upend many of the long-standing rules around manufacturability - allowing engineers and designers to place a part’s function at the center of their design considerations. Download Now
Taking Control of Engineering Documents
This ebook covers tips for creating and managing workflows, security best practices and protection of intellectual property, Cloud vs. on-premise software solutions, CAD file management, compliance, and more. Download Now

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close