Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Buffer overflow serial communication: ThorLabs PM100

Buffer overflow serial communication: ThorLabs PM100

Buffer overflow serial communication: ThorLabs PM100

i have been having a buffer overflow problem with my a power meter by Thorlabs PM100. it says that there is some kind of buffer overflow when reading the data from the comm port. I used the NI website for help and tried to reduce the tranfer information using the Instrumentation and Automation program. However, the problem still persists. Also, just for more info. i am using the serial communication example vi from the labview 5.1 . I was wondering if anyone has any kind of solution to this problem. Any links to help get rid of this buffer overflow will be greatly appreciated. OH and the device is being detected, the only problem is that at the very last step when the data is being read, LabVIEW reports a buffer overflow error. THANKS!

RE: Buffer overflow serial communication: ThorLabs PM100

If Labview is overflowing, increase the size of your buffer in Labview.  If your instrument buffer is overflowing, increase the communication throughput.  (Is GPIB faster than serial?)

RE: Buffer overflow serial communication: ThorLabs PM100

Thanks for ur reply melone, here's something else im adding, so that you are able to see my problem more clearly:

I input a command (ex: *TST?) in labVIEW and run the serial communication VI. The output after a clean run should be '0'. But, it says that there is some kind of buffer overflow. My bytes to read is set to 4. I change this to many different numbers, and i still get the same error. Now, if i change this byte read number to 0, the simulation runs fine, with no error. What does this mean???!

Also, do my labVIEW "baud rate" and device "baud rate" have to be the same? i am new to labVIEW altogether, so i dont even know what baud rate is.

My other guess was that the buffer/register of my device (power meter) might have information in it already, so i tried to clear it by the clear commands using the device's manual, that didnt do anything either.

Also, does it make a difference if the termintion character is ON or OFF under the subVI of "VISA Serial" ? i mean, either way, i get the same buffer overflow error.

Anyway, this is all the stuff i have done and make gotten the same error. After reading this, do you have any other suggestion? i am kinda stumped at this point. Do you think that i shouldnt be even using that example serial comm.VI. Any kind of suggestion that might give me any insight will be greatly appreciated. THANKS!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close