×
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Problem importing from excel in MSP2003 (Work well in MSP2000)

Problem importing from excel in MSP2003 (Work well in MSP2000)

Problem importing from excel in MSP2003 (Work well in MSP2000)

(OP)
Hello,

  I have a compatibility problem with MS Project 2003. I have one macro to
generate the MS Project Plan. This macro has three sources of information.
These sources are three ".CSV" files with the tasks, resources and assignment
information, and I have three mapping for each of them. The following piece
of code shows how data is imported:


...

    FileOpen Name:= Path & Tasks, _
                    ReadOnly:=False, _
                    Map:="All_Tasks"
                   
    FileOpen Name:= Path + Resources, _
                    ReadOnly:=False, _
                    Map:="All_Resources"
                   
    FileOpen Name:= Path + Assignments, _
                    ReadOnly:=False, _
                    Map:="All_Assignments"
...


The import orden is very important, and this can't be changed. I made
different test and I found that the problem appears when the last
import(Assignment) is executed.

I think that the map of "All_Assignments" is not mapping correctly, because
when I correct this and I didn't do any changes in the mapping, and then in
the "Import Wizard - Map Options" I picked the button "Finish", all the value
tasks in the "work" column look like fine minus only one of them, so I edit
the Map again and when I reached the "Map Options" in the "Import Wizard" and
I picked "Finish" button, before that all the value tasks look like fine.

This macro works fine in the MS Project 98 and Ms Project 2000.

There is a well known fixed problem here?

I've installed the service pack 1 however the problem stills continue.



Thanks in advance.
Kanthong Vannasaeng


 
 
 
    

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members! Already a Member? Login



News


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close