INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

ExcelVBA error: "License Not Found"

ExcelVBA error: "License Not Found"

(OP)
I've been using excel to run ESRD StressCheck through its COM API interface. Never had any issues with this, works just fine. I recently had a standalone "spinoff" program called StressCheck ToolBox installed, which has a similar COM API but with its own object library. The library is recognized by excel just fine, and everything in the registry is pointing to the right place. However, when I execute a macro for this program, I get the following error:

"License information for this component not found. You do not have an appropriate license to use this functionality in the design environment."

Searching the internet shows that this error isn't all that uncommon, but it seems like people who encounter this have it happen across the board for any macro they try to run. In my case, it's just this one program I get this error for. It works fine for any other program. There are executables floating around that apparently fix this for the people whose macros don't work at all, but this is a work machine that I'm not able to run any unapproved .exe file on, so that isn't an option. And it seems like my issue is a little bit different, anyway. I'm not a VBA genius, so I really don't have any idea how to tackle this. Any input is much appreciated

RE: ExcelVBA error: "License Not Found"

I had this happen a while ago, I cannot remember what caused it and what I did to fix it but I did solve the issue. If I had to guess casting my mind back it was something do do with a missing file relating to a reference to an active x control I had in a form in a word file (in vba window goto tools/references and see if anything is ticked but listed as missing, but you note excel sees you reference object). I added a library file required and registered it based on some instructions I found. Cannot recall 100% though.

If it's a third party programme just ask the developer.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!


Resources


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close