INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Erroneously Snapping to Lines that don't exist (AutoCAD 2015)

Erroneously Snapping to Lines that don't exist (AutoCAD 2015)

(OP)
Today AutoCAD (2015) has started snapping to lines that don't exist (please see attached image).

The only OSnaps I don't use are Node, Quadrant, Insertion & Nearest. I don't usually use Apparent Intersection but it is currently on & all others are always turned on.

No, regen won't help, neither of the lines in the attached png are curves, they are very much straight lines.
No, I haven't zoomed in too far causing the graphics to jump out of alignment.
And lastly
No, there are no lines on other layers in the same general vicinity.

Does anyone have any ideas why this could be happening & (in an ideal world) a solution to my problem? I'm wasting so much time over this.

RE: Erroneously Snapping to Lines that don't exist (AutoCAD 2015)

Is your grid turned on?

osnap>>snap & grid


RE: Erroneously Snapping to Lines that don't exist (AutoCAD 2015)

(OP)
Good thought, but sadly it is not.

RE: Erroneously Snapping to Lines that don't exist (AutoCAD 2015)

Is it happening in all drawings? Could you upload a small drawing with the problem - but if it's a glitch on your end we wouldn't see it.

RE: Erroneously Snapping to Lines that don't exist (AutoCAD 2015)

(OP)
Hopefully I'll have a moment tomorrow to remove all the confidential information from this drawing.

RE: Erroneously Snapping to Lines that don't exist (AutoCAD 2015)

(OP)
Ok, this is only a couple of components, but it is still snapping to intersections that don't exist, so I think it'll do.

Two blocks, pick points should be in the same place, but I left them where they wanted to snap, that way even if it doesn't work on your computer, you can still see where it thought there was an intersection to snap to.

drawing is in 2013 format, can re-save in an earlier format if necessary.

RE: Erroneously Snapping to Lines that don't exist (AutoCAD 2015)

I also experience intersection snaps appearing where there is no intersection.

The problem is related to the objects being at very large coordinates, well over 1 million.
AutoCAD's calculations can't deal with the required accuracy for various things to work correctly; apparently some object snaps included.
If you move these objects closer to the origin, shouldn't have this error.

RE: Erroneously Snapping to Lines that don't exist (AutoCAD 2015)

(OP)
I rarely consider the location of the origin in AutoCAD & I've never had that problem before, but that does sound like a potential solution. I'll move everything closer & see what happens. Cheers.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!


Resources


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close