INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Issues with Donut command

Issues with Donut command

(OP)
I'm having some strange problems with the Donut command! I work with process piping and use a small donut to indicate weld dots on piping ...only been doing this 25 yr.s or so. BUT as we all know AutoCAD "up-dates" (I used the term loosely) the program, so that what has worked fine for the last decade, now has issues ...and mine are these donuts. SO I'm into my drawing and it's about 90% now, but I'm now seeing problems with the donuts I have used. Some are cut in half (that's all you now see and plots that way), then some are now "square" shape, they can no longer be picked with the center snap point, then worst case they just go to a line (always horizontal, never vertical) in the location I have put them!?? I've been looking on the internet for some help, I believe I have solved the issue with the donuts being cut in half, issues with the "OverKill" command, but that's it, I can't find anything on the square shape or the going to a line issue. Any I.T. or AutoCAD wizards out there that can give we any ideas!?? I'm working with AutoCAD 13 at present.

RE: Issues with Donut command

Welcome to the 1990's smile

Since the donut is made with two semi-circular polylines, I assume you have a donut that shows only one of the segments, when you say they look "cut in half".
Is it exploded? Has it been trimmed?
Check the line type - if it's a hidden line scaled just right, it might look pretty funny.

STF

RE: Issues with Donut command

(OP)
As I had said, the "cut in half" donuts are and issue with Overkill command, you have to check the box that indicates NOT to break polylines, before you execute the command. You do this and the problem goes away. BUT I still have the issue with "square" donuts and/or "just a line" type donuts, any answer(s)??? ...I've been doing this "stuff" since I got out of the Army in 76, back in the "on the board" days, and was only pushed into AutoCAD back in 89 actually ...with the promise to "make my life easier" ...WELL it hasn't done that! But what it has done is make a lot of "smart" computer operators, and some really "dumb" piping designers! My only hope is to squeeze out another 5, I'll be happy, and the industry will be ..."some place" ...without a paddle! ;)

RE: Issues with Donut command

Alas, there's little I can do about your quality of life.
And I haven't been able to replicate your problem in AutoCAD R14. I remember R13 - very buggy implementation on windows 95, as I recall. Not that that has much to do with your problem, not likely.

The command "OVERKILL" is not available in my R14 release. It is in my 2009 release. Bit of a mystery there.

When I try to replicate your problem in Acad 2009 I just cause other weird things to happen, not your problems.

It is possible the poly-lines that used to be your donut arcs have been converted into splines, or "curve-fit" in some way to the 2-point origins of the arcs they start with. Overkill has a tolerance (in 2009 it's called "FUZZ") which you may have inadvertently made too coarse - mine is set at 0.000001 by default.

Perhaps the scale of your drawing has extents that are dramatically larger than the detail drawing objects. In which case maybe this is just a "VIEWRES" setting that is showing you lines are blocky when nothing has actually changed at all. I set VIEWRES to 20,000 whenever possible.

STF

RE: Issues with Donut command

(OP)
I need to make one correction here, I said AutoCAD 13, I meant 2013. Don't know any body around here that isn't up to 2010 at minimum. And your are right, I'm still trying to forget AutoCAD 13!!! ;)

RE: Issues with Donut command

ACAD-13 - YIKES ! [ ;) ]

Haven't encountered this one (I'm at 2012) but the square donut thing - is your VIEWRES set high enough ? I use 2000 minimum. Still, don't see the plotting thing. even at low viewres, I'd think the plot would come out right.

Whew !

Good Luck !

-C.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!


Resources


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close