INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Log In

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Double-click shut-down. Setting to shut it off?

Double-click shut-down. Setting to shut it off?

(OP)
I'm now using Inventor 2014, though this has been an annoyance since I started in 2012.

Is there any way to disable the ability of Inventor to close all files and exit immediately, with a simple double-click of the "I" in the top-left corner of the ribbon menu?



Having searched the Autodesk forum for tips, all I come up with is "it's standard ribbon behaviour (why would you complain about that?)"
Well, just because Microsoft Excel and Word have the same annoying problem, that doesn't mean you have to allow your own software to tick your users off.
There are so many many ways to make Inventor close, I really don't need another. (Some days, it's all I can do to keep the program running sad)

Has anyone found a way to modify the ribbon functions to prevent closing of the program if it's double-clicked inadvertently?

STF

RE: Double-click shut-down. Setting to shut it off?

I never knew about that functionality until you described it. Now I'm worried I'll start doing it all the time, like scratching an itch...argh!

RE: Double-click shut-down. Setting to shut it off?

Its not really as bad as described here. You still get the opportunity to save files that require a save.

Is your double clicking of the Application Menu something that when you do, there is a lag in the software. This is an indication that you might need to upgrade your machine as I haven't ever had a lag issue on my machine, but on older hardware it is much more prominent.

Maybe consider using hotkeys instead or making a makeshift CTRL+RMB Marking Menu for the commands you use there most.

RE: Double-click shut-down. Setting to shut it off?

(OP)
Yes it's all about the lag in the software.
24 GB of ram isn't enough?

Looking into it more, it is a Microsoft problem, not so much an Inventor problem. Autodesk was stuck with all the features and problems involved in the Ribbon once MS introduced it, and Adesk decided to go with it. In AutoCAD I have the workspace configured with "RIBBONCLOSE" in effect but that option isn't available in Inventor. Considering the workflow I don't think keyboard input in Inventor is the way to go. Key board shortcuts that change depending on the environment and type of model/drawing have proven to be very hard to memorize (I've tried).

STF

RE: Double-click shut-down. Setting to shut it off?

Seems odd that you would have ANY lag considering I have 1/4 of that RAM and experience zero lag on the Application Menu.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Eng-Tips Forums free from inappropriate posts.
The Eng-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!


Resources


Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close