Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Eng-Tips
*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

jvacierto (Automotive)
24 May 12 12:15
Hello, our company has the 64-bit version of NX 7.5.4.4 installed on our workstations and for some reason, it won't use more than about 2GB of RAM. We have Windows XP x64 and from 8 to 16GB of RAM installed on the all the workstations. I've tried tweaking various Windows parameters (including adding /3GB to the boot.ini file) and nothing seems to work. Are there settings or defaults in NX that need to be changed? Has anyone else ever run into this issue?

Any help would be appreciated.
Toost (Mechanical)
24 May 12 14:28
The /3gb switch should be invalid on a 64 bit computer since that limit simply isn't there.
If the Ugraf.exe process don't use more than 2Gb of ram on your system it should rather be that your parts and assemblies don't need more than that.
The main difference from the user perspective when comparing 32bit to 64bit computers running NX is that the 64 bit don't slow down and finally crash when the ugraf.exe closes in on the 32 bit RAM limit .
If the ugraf.exe is larger, say 8Gb there is so much data in the session that the process will be slow no matter what processor is feeding it . -The smaller the memory footprint the better...

But this might not have been the question ?
Regards, Tomas
JohnRBaker (Mechanical)
24 May 12 15:17
How are you checking the memory used by your NX session? In addition to the OS tools, you can also go to...

Help -> About NX

...and select the button labeled 'System Information' to get a complete picture of the how the current session of NX is using system resources and what the available limitations are.

John R. Baker, P.E.
Product 'Evangelist'
Product Engineering Software
Siemens PLM Software Inc.
Industry Sector
Cypress, CA
Siemens PLM:
UG/NX Museum:

To an Engineer, the glass is twice as big as it needs to be.

jvacierto (Automotive)
24 May 12 15:58
This is has been an ongoing problem. We've definitely worked on models that have required more than 2GB (we work on commercial and military trucks). We're going to do a clean install of NX on a computer with Windows 7 64-bit to test it, but switching all the computers to 7 is not an option at the moment.

Does NX have memory allocation settings anywhere in the program?
jvacierto (Automotive)
24 May 12 16:09
We do use the Help -> ABout NX -> System Information window, then we also check the memory allocation in the Windows Task Manager. Both of those numbers match pretty closely.
Toost (Mechanical)
24 May 12 16:43
What happens when "you realize that NX requires more than 2Gb"?

At my current assignment, they design very-very large assemblies. We regularly did hit the 32bit RAM limit when processing Drawing views. ( the sessions crashed or did not finish) This problem disappeared after switching from Win XP 32bit to Win 7 64bit. - And since the problem disappeared i seldom check how much RAM NX is using..
Processing drawing views still takes a long time, but we try to do it over night. - Start it when it's time to leave for the day and save the drawing in the morning.
Regards, Tomas
Walterke (Industrial)
25 May 12 2:18
Task manager makes it pretty easy to check...
If you see it max out on 2GB you're pretty safe to say something is wrong. Whether it's an NX or a windows problem is another thing.

Have you tried running another program to max out your RAM?

About memory allocation: I only know those for CAE, but that doesn't seem to be the issue here. I'd check if it's NX first before I start digging around in the settings.

If all else fails, contact gtac.

NX 7.5.5.4 with Teamcenter 8 on win7 64
Intel Xeon @3.2GHz
8GB RAM
Nvidia Quadro 2000

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!

Back To Forum

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close