INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Eng-Tips
*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

SolidWorks 2010 Hole Wizard

SolidWorks 2010 Hole Wizard

(OP)
When trying to edit a part that has features done with a hole wizard, an error pops up saying "Out of memory or other error trying to initialize data source from standards file." Then it gives the file path located on the C drive. I tried moving the file onto the main server where the particular part is located, but the error still appears when trying to edit the hole feature. If SolidWorks is completely closed and restarted, the error wont appear for a while.

RE: SolidWorks 2010 Hole Wizard

To clarify;
The Hole Wizard works OK in a new session of SW, but after working on the model for a time the error message appears?

What are your system specs? (CPU, RAM, VM setting, 32 or 64 bit)

 

RE: SolidWorks 2010 Hole Wizard

(OP)
Usually the error message pops up when the part is first brought up to edit, then once it appears, closing solidworks completely and re-opening it allows it to work, but not always. As far as the computer specs, I am not sure, but it is a very small part that is causing the problem. There is no problem running extremely large assymblies with very complex layouts. So I find it hard to believe that it has anyhting to do with the computer capabilities. I was wondering if it had anyhting to do with the Hole Wizard favorite function? The path it says that wont work is a file that is a HoleWziardFavorites.mdb. I think it has something to do with that or the fact that the favorite was located on the C drvie, but it still did it when I moved the file into the same file as the part itself.  

RE: SolidWorks 2010 Hole Wizard

The file should be located wherever the Tools > Options > System Options > File Locations > Hole Wizard Favorite Database is pointing to.

RE: SolidWorks 2010 Hole Wizard

I came across this same error message a couple of times without being able to know why. My best guess would be that the temporary folder or something like that becomes overloaded but I didn't search for the real reason.

Patrick

SolidWorks 2010 SP4
ThinkPad W500
Core 2 duo P8800 2.66 GHz
3 GB Ram
ATI Fire GL V5700
Windows XP SP3 (32bit)

RE: SolidWorks 2010 Hole Wizard

Engflex,
Welcome to my world.....This is an ongoing tech issue with my VAR. Are you on a 32 bit system, and how much memory do you have? I do not see this on my 64bit system at home, so I think it's a 32 bit issue.

Colin Fitzpatrick (aka Macduff)
Mechanical Designer
Solidworks 2010 SP 3.1
Dell 490 XP Pro SP 2
Xeon CPU 3.00 GHz 3.00 GB of RAM
nVida Quadro FX 3450 512 MB
3D Connexion-SpaceExplorer

RE: SolidWorks 2010 Hole Wizard

Engflex,
Forgot to add I have to perform the same exact steps as you as far as closing and reopening files. It's a real PITA! Try and keeps other apps open to a minimum.  

Colin Fitzpatrick (aka Macduff)
Mechanical Designer
Solidworks 2010 SP 3.1
Dell 490 XP Pro SP 2
Xeon CPU 3.00 GHz 3.00 GB of RAM
nVida Quadro FX 3450 512 MB
3D Connexion-SpaceExplorer

RE: SolidWorks 2010 Hole Wizard

I have the same problem. I'm running SW2011 SP1.0, 64 bit with an AMD Dual Core 3.0 Ghz processor, 8 GB Ram, & nVidia Quadro FX 4000 with 1.5 GB Ram. This doesn't come up all the time, but when it does I can't get rid of it no matter what I do. So I just bite the bullet and "repair" the software to start over. When I'm crunched for time and can't repair, I just extrude cut a hole to keep working and remember to annotate it correctly on the drawing. I have had to do this (repair) at least 4 times since 2011 came out. I never had the problem with SW2010 thru SP4.0. I only recently upgraded to 64 bit two weeks ago but I had this error pop up previously running the 32 version of 2011 as well. I have experienced some other strange happenings with SW2011 in 64 bit mode, to the point I am taking a day off to be on line with my VAR all day if need be so he can experience them himself. (I need the break anayway).  

RE: SolidWorks 2010 Hole Wizard

Question are all of you pointing to a network location for the hole wizard and toolbox or are you local on you c drive?

Colin Fitzpatrick (aka Macduff)
Mechanical Designer
Solidworks 2010 SP 3.1
Dell 490 XP Pro SP 2
Xeon CPU 3.00 GHz 3.00 GB of RAM
nVida Quadro FX 3450 512 MB
3D Connexion-SpaceExplorer

RE: SolidWorks 2010 Hole Wizard

In my case it's all local to drive c. SW is pointing to the correct location for the hole wizard - it hasn't been moved about. Unless an alien is tapping into my computer and moving files, that issue can be thrown out as a possible source of the problem.

RE: SolidWorks 2010 Hole Wizard

Na, it's not an alien....our government is already doing that.

}:O)

Colin Fitzpatrick (aka Macduff)
Mechanical Designer
Solidworks 2010 SP 3.1
Dell 490 XP Pro SP 2
Xeon CPU 3.00 GHz 3.00 GB of RAM
nVida Quadro FX 3450 512 MB
3D Connexion-SpaceExplorer

RE: SolidWorks 2010 Hole Wizard

(OP)
On the problem I am seeing, the file is pathing to the C drive, but the part is located on a shared drive. I have moved the file to the same folder as the project is in and the problem is still occuring. It calls out a fuile that is labeled Hole Wizard Favorites. I have searched for errors associated with it and ahve not found anything.  

RE: SolidWorks 2010 Hole Wizard

All my SW options point to the network. Toolbox, Hole Wizard, templates yada, yada, yada. Some of the assemblies, parts and drawings for my programs are sometimes on the network, and I work off of that. Other times assemblies, parts and drawings for my programs are sometimes on the c-drive, and I work off of that.

Colin Fitzpatrick (aka Macduff)
Mechanical Designer
Solidworks 2010 SP 3.1
Dell 490 XP Pro SP 2
Xeon CPU 3.00 GHz 3.00 GB of RAM
nVida Quadro FX 3450 512 MB
3D Connexion-SpaceExplorer

RE: SolidWorks 2010 Hole Wizard

The question of whether file locations are pointing to network or local drive is not the problem. I'm running SW on a local drive only - not connected to a network in anyway shape or form. I guess this problem goes beyond this forum and I'll submit it to SW directly.  

RE: SolidWorks 2010 Hole Wizard

I didn't directly say it was the problem....I was trying to find it was part of the problem.

Let us know what you come up with, thanks,

Colin

Colin Fitzpatrick (aka Macduff)
Mechanical Designer
Solidworks 2010 SP 3.1
Dell 490 XP Pro SP 2
Xeon CPU 3.00 GHz 3.00 GB of RAM
nVida Quadro FX 3450 512 MB
3D Connexion-SpaceExplorer

RE: SolidWorks 2010 Hole Wizard

EngFlex,
Any fix on this? Are you still experiencing the problem?

Colin Fitzpatrick (aka Macduff)
Mechanical Designer
Solidworks 2010 SP 3.1
Dell 490 XP Pro SP 2
Xeon CPU 3.00 GHz 3.00 GB of RAM
nVida Quadro FX 3450 512 MB
3D Connexion-SpaceExplorer

RE: SolidWorks 2010 Hole Wizard

Check out service request SR# 1-1673645161.  This has been an ongoing problem for the last few releases.  There are some BAT files to run the fixes the problem in most cases.

RE: SolidWorks 2010 Hole Wizard

I did the bat thing, and didn't work. Thank you for the SR number.

Colin Fitzpatrick (aka Macduff)
Mechanical Designer
Solidworks 2010 SP 3.1
Dell 490 XP Pro SP 2
Xeon CPU 3.00 GHz 3.00 GB of RAM
nVida Quadro FX 3450 512 MB
3D Connexion-SpaceExplorer

RE: SolidWorks 2010 Hole Wizard

gfranck10 ... Do you have an SPR# associated with that service request?

RE: SolidWorks 2010 Hole Wizard

(OP)
I have not found any fix for the problem yet.  

RE: SolidWorks 2010 Hole Wizard

This error is memory killing me!!!!!!!!

Colin Fitzpatrick (aka Macduff)
Mechanical Designer
Solidworks 2010 SP 3.1
Dell 490 XP Pro SP 2
Xeon CPU 3.00 GHz 3.00 GB of RAM
nVida Quadro FX 3450 512 MB
3D Connexion-SpaceExplorer

RE: SolidWorks 2010 Hole Wizard

EngFlex, any progress on this?
 

Colin Fitzpatrick (aka Macduff)
Mechanical Designer
Solidworks 2010 SP 3.1
Dell 490 XP Pro SP 2
Xeon CPU 3.00 GHz 3.00 GB of RAM
nVida Quadro FX 3450 512 MB
3D Connexion-SpaceExplorer

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close