Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Eng-Tips
*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

How do I make sketch lines that are behind a solid not show?Helpful Member!(2) 

superart (Mechanical)
6 Jun 10 23:39
I have a solid model, and I am creating some sketch lines that are on the surface of this model.  The problem is, as I rotate the model, the lines that are behind it still show through.

How do I get them to stop showing through.

I checked the transparency of the solid feature and it is not transparent.  I looked through the settings, and could not find anything to fix this.  If anyone could help me out with this, I would greatly appreciate it.

I have attached a screen-shot to better illustrate what I mean.

Thanks much,
--Art.

Helpful Member!  ctopher (Mechanical)
6 Jun 10 23:57
Uncheck "View/sketches".

Chris
SolidWorks 09 SP5.0
ctopher's home
SolidWorks Legion

Helpful Member!  Gurjjeet (Mechanical)
6 Jun 10 23:58
Right click the sketch in Feature tree & hide it.

If you want to show some sort of line work on the one side of model & do not want to show on the other. I would suggest useing split line & split the face or use cut extrude with very small value(e.g. 0.001)

Hope that helps.
 
superart (Mechanical)
7 Jun 10 0:20
I want the sketch to show up, so I don't want to hide it.  I just want the parts of a sketch that are behind a solid object to not show.

gurjjeet, thanks for the help.  Your suggestion of making it an extrude cut doesn't work, since it wants to cut the entire model all the way through because Im using just a line as the "cut shape".  However, if I do it as an extrusion, then it does work.

However, it just seems like there should be a setting or something in solidworks that I can check a check box and make it so that sketches don't show through solid features.

I guess this is a good enough workaround, thank you for the very quick response, I appreciate it.
Gurjjeet (Mechanical)
7 Jun 10 0:30
in that case, use thin feature with very small value for thickness as well.
superart (Mechanical)
7 Jun 10 0:49
Yea, that's basically what I did.
Thanks.

I wonder if there is a way to contact solidworks to suggest features for future versions.  This really should be just a check box option.
Gurjjeet (Mechanical)
7 Jun 10 1:24
contact your VAR or log on to your customer portal & put in an Enhancment Request for the feature/s you want to be included in future versions of SolidWorks
sonewone (Bioengineer)
8 Jun 10 8:09
That might be a good feature. Sketches to behave like a model edges. Hide when behind a face. Cool thought.
I believe its not currently in SW, can be an enhancement.

Thanks
mjcole (Mechanical)
9 Jun 10 20:32
If you create an Extruded surface of the sketch then SolidWorks will calculate the Hidden Line display and not show you portions behind the solid.



I have never noticed this or cared about it in SolidWorks before you mentioned it.

There should be an option like hide sketch behind solids in Sketch or Display Options.

Michael
superart (Mechanical)
9 Jun 10 21:18
What do you mean?  I tried extruding a solid and a surface, and the sketch still shows through.  I tried extruding it from the same plane and from a different plane "in front" of the sketch.  Still shows through.


I agree, I never really noticed it before either.  But I am working on a model for a client, and we are still in the conceptual phase, so I just made a very basic model.  The final design will have ribs inside for support, so he asked me to "show lines where the ribs will be".  the entire surface is curved, so I did 3D sketches and constrained them to stick to the surface, I thought this would be enough, but it was really confusing looking when I noticed that lines were showing through the actual model.  So I just made a very thin extrusion of something like .0001" using the sketches I made, and it seems to be working fine now.  It's just a conceptual model at this point, so I don't think the extra extrusions should be a problem.
Updraft (Mechanical)
10 Jun 10 8:59
Superart,

When a sketch is in the feature tree without being in a feature it defaults to being visible.  When it is absorbed into a feature it gets set to hidden by default.  If your sketch is still showing then it must at some point have been set to "Show", probably in your efforts to control its visibility.  All you need to do is RMB on the sketch and change its visibility state to "Hide".

- - -Updraft
superart (Mechanical)
14 Jun 10 22:11
updraft,

The sketch is not part of a feature, it is just referenced to it.  I don't want to hide it.  I want the feature to show up in the 3D view.  The thing is, it is showing up "through" the 3D feature.  It's as if the 3D feature is transparent (transparency is turned off).

Basically, imagine extruding a cube.  Now make a 3D sketch, and draw a line around the entire cube, this gives you a square that is on the surface of the cube, kind of like an equator.  Now, what I want is for the part of the sketch that is in front of the cube to show up, but the part of the sketch that is on the other side of the cube to not show up since the cube is in front of it.  But the problem is, the whole sketch is visible, even the parts that are behind the cube.
AnnaWood (Mechanical)
15 Jun 10 0:39
You will not be able to change that behavior.  That is the way SolidWorks is coded to work.

Sorry,

 

Anna Wood
Core i7 EE965, FirePro V8700, 12 Gb RAM, OCZ Vertex 120 Gb SSD, Dell 3008WFP 30" Monitor
SW2010 SP2.1, Windows 7 x64
http://www.solidmuse.com
http://www.phxswug.com

Updraft (Mechanical)
15 Jun 10 11:51
superart,

SWX doesn't do what you want so you'll have to find another way.  Methods have already been supplied to you in the above responses that will achieve the result you are after, but you'll have to make the sketch into a feature.  There is no way around it.

- - -Updraft
superart (Mechanical)
15 Jun 10 14:36
Yea, I found a work-around. Gurjeet's solution is what I went with, and it works well enough for what I am trying to do.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close