Smart questions
Smart answers
Smart people
Join Eng-Tips Forums
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Eng-Tips
*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Getting forrtl: severe (24): end-of-file during read, unit 8

LongLe (Specifier/Regulator) (OP)
8 Jul 09 15:14
My FEA software crashes every time I run a mechanical event simulation. See attached pic showing error message. It has no problems running static analysis. I have attempted running a tutorial file included with the install to determine if the problem was operator-error on my part and had the same error message come up.
 
GBor (Mechanical)
9 Jul 09 9:31
This error is probably bigger than a web forum can handle, but let's give it a shot anyway:

What version of the software are you running?

Have you updated all of your drivers?

In your simulation, are you simply dropping a block?  Or do you have contact surfaces and other complexities?

What are your computer system specs?

Are you running the software off of a network?  Or locally?  

Is the file located on a network?

Do you have rights to the event simulation capability?

Is your license node-locked, or floating?

Have you checked to make sure your video card can handle the simulation output?

At one point in the analysis does this error occur?  Immediately?  After the model verification?  Memory Allocation?  During the analysis?

I'm sure there are more questions, but this is a start.

GBor

Garland E. Borowski, PE
Engineering Manager
Star Aviation

Dengr1 (Mechanical)
9 Jul 09 11:41
Maybe I am missing something but I am not seeing the attatched file
LongLe (Specifier/Regulator) (OP)
9 Jul 09 12:25
Sorry looks like it didnt post. Thanks for the response guys. I am gathering the information right now  
LongLe (Specifier/Regulator) (OP)
9 Jul 09 13:15
What version of the software are you running?  23.1

Have you updated all of your drivers?  You tell me - I don't have permission to check.

In your simulation, are you simply dropping a block?  Or do you have contact surfaces and other complexities?  Using the piston tutorial.  Error occurs in other models as well.

What are your computer system specs?

-Processor: Intel Pentium D 3.4GHZ

-Video Card: Nvidia Quadro FX 1400

-Memory: 4 GB

Are you running the software off of a network?  Or locally?   Local

Is the file located on a network?  File is local

Do you have rights to the event simulation capability?  Yes

Is your license node-locked, or floating?  Node-locked (I think)

Have you checked to make sure your video card can handle the simulation output?  How does one do that?   

At one point in the analysis does this error occur?  Immediately?  After the model verification?  Memory Allocation?  During the analysis?   Error occurs during analysis.

 
LongLe (Specifier/Regulator) (OP)
9 Jul 09 13:17
Sorry about this part "Have you updated all of your drivers?  You tell me - I don't have permission to check. " No not all drivers are up to date
Zapster (Electrical)
9 Jul 09 13:28
LongLe,

23.01 is the latest build of the software (I think) so you should have full customer support from Algor.  What did the folks at Algor have to say about your problem?
LongLe (Specifier/Regulator) (OP)
9 Jul 09 13:34
To look online to see if I can find out anything and then to call them back if I still have issues...
Zapster (Electrical)
9 Jul 09 13:46
LongLe,

I would have told them that there is no need to call back if you have issues because an answer like the one you posted would have given me some real issues with the support group at Algor.

Contact your sales rep and request a contact number for someone who will help.  I have been harsh on the folks at Algor in the past; however, with this type of customer support it sounds like Algor may be going out of business.



  
Dengr1 (Mechanical)
9 Jul 09 16:53
I have had similar (very bad) experiences with algor support.  We just had them in for training and it was a complete disaster.  Anyway I know this does not help you solve your problem LongLe.  You might want to see if there is a description of this error message in you help menu.  Algor does have some standard error messages listed there although this does not seem to be an error message.  Error or warning messages are coded differently.  You might also try and see if you can run the analysis on a different machine.  If the problem is duplicated then we know it is a program issue and not a hardware issue.  I have had to do this to diagnose problems with algor.  Also try and change solvers.  Does your fempro crash and close or does the analysis just stop?
johnhors (Aerospace)
10 Jul 09 5:06
I am not an Algor user, but I can recognise that this is a fortran run-time error message and not something that Algor would have written into their program.

An "end-of-file during read" error message is very easy to trap and circumvent in fortran, it shows poor programming when an end user is exposed to this.
GBor (Mechanical)
10 Jul 09 16:50
You need to reregister your .dll's.  There is an executable that you need to run.  I can't remember what it is off the top of my head and I'm not at work to look, but that is your problem.
GBor (Mechanical)
10 Jul 09 16:54
Algor isn't going out of business, but their recent acquisition by Autodesk may hurt them for a while.  They laid off a good portion of their account representatives as of June 5th.  I have no idea what they've done with the tech support group since then, but the overhaul of their staff has not been a good realignment in my opinion.

I'm pretty confident in the .dll reregistration, though.
GBor (Mechanical)
13 Jul 09 14:40
I believe the file to run is Regall.bat.  This will bring up a Dos Command window that will say it is registering all the .dll's, ocx's, etc. in you ..\Algor\23.00 subdirectory.  The mouse will indicate that something is happening.  And then, after a while, the dos window will disappear.

I know there is a "pretty" Windows version of this, but I believe they both call the same registration.

Alan Fowkes at Algor's tech support will know this.  I believe he wrote the original registration program.  No idea who you spoke to that wouldn't know this.
LongLe (Specifier/Regulator) (OP)
15 Jul 09 11:35
Hey Guys,

Still same issue after running the regall.bat I check the event logs to make sure the batch was not erroring out and its now. I guess I will see if Algor do soemthing about this issue...Ill let you guys know if they fix it....
GBor (Mechanical)
15 Jul 09 14:27
Ask them what the .dll registration executable file is...perhaps regall.bat isn't the right one, but I'm pretty sure it will solve your problem.
LongLe (Specifier/Regulator) (OP)
15 Jul 09 14:31
ok will do THanks GBor. Ill update that once I give them a call Probally tomorrow
eteoh (Mechanical)
20 Jul 09 12:48
I do have the same problem too. Please let me know if there is a resolution for that. Thanks.


forrtl: severe (24): end-of-file during read, unit 40, file C:\temp\test2.ds_data\1\ds.ssc
Image              PC                Routine            Line        Source             
arun4.exe          0000000140DDCBF4  Unknown               Unknown  Unknown
arun4.exe          0000000140DD840D  Unknown               Unknown  Unknown
arun4.exe          0000000140D7AFDE  Unknown               Unknown  Unknown
arun4.exe          0000000140D64645  Unknown               Unknown  Unknown
arun4.exe          0000000140D63AE5  Unknown               Unknown  Unknown
arun4.exe          0000000140D3C0D3  Unknown               Unknown  Unknown
arun4.exe          00000001406DAAD2  ELCAL                     620  xelcal.for
arun4.exe          0000000140355090  FMAIN                     613  yapak4.for
arun4.exe          00000001407A0072  MAIN__                    367  fallocn.for
arun4.exe          0000000140DE51B4  Unknown               Unknown  Unknown
arun4.exe          0000000140DB7FB5  Unknown               Unknown  Unknown
kernel32.dll       0000000077D596AC  Unknown               Unknown  Unknown
eteoh (Mechanical)
20 Jul 09 12:59
Just another small note i wanted to add.
I did send my model to Algor support, they don't have problem running the same model at their end at all.
 
abing (Mechanical)
28 Jul 09 10:56
Hi Longle and eteoh,

Both of your machines are 64 bit or 32 bit?
 
LongLe (Specifier/Regulator) (OP)
30 Jul 09 15:16
I am running Windows 32 Bit
abing (Mechanical)
7 Aug 09 12:57
Longle,
It should work if you use administrator on your machine.
lfunk (Mechanical)
11 Aug 09 17:13
I have a similar error (shown at bottom) that I received after installing on a new quad core.  The analysis worked before on the old machine, and it apparently works for my Algor rep.

I believed it must be an installation issue.  I re-installed it and I still get the same error.  I am an administrator on this machine, so that isn't the solution.

Please let me know if any of you have resolved this.

forrtl: severe (39): error during read, unit 40, file C:\I3508P_Leavitt_ROPS_2\FEA2-I3508-0000.ds_data\5\ds.ssc

Image        PC        Routine  Line     Source             
arun4.exe    0000000140DDCBF4  Unknown  Unknown  Unknown
arun4.exe    0000000140DD840D  Unknown  Unknown  Unknown
arun4.exe    0000000140D7AFDE  Unknown  Unknown  Unknown
arun4.exe    0000000140D64645  Unknown  Unknown  Unknown
arun4.exe    0000000140D63AE5  Unknown  Unknown  Unknown
arun4.exe    0000000140D3C0D3  Unknown  Unknown  Unknown
arun4.exe    00000001406DAAD2  ELCAL        620  xelcal.for
arun4.exe    0000000140355090  FMAIN        613  yapak4.for
arun4.exe    00000001407A0072  MAIN__       367  fallocn.for
arun4.exe    0000000140DE51B4  Unknown  Unknown  Unknown
arun4.exe    0000000140DB7FB5  Unknown  Unknown  Unknown
kernel32.dll 000000007773BE3D  Unknown  Unknown  Unknown
ntdll.dll    0000000077946A51  Unknown  Unknown  Unknown
 
lfunk (Mechanical)
11 Aug 09 17:18
I forgot to mention that I am using a 64 bit machine.  Also, I tried the Regall.bat and got several "Access is denied" sequences when I run it, then it errors out.
LongLe (Specifier/Regulator) (OP)
12 Aug 09 9:27
I just talked to Algor and they said try installing it on a different machine because they said it soulds like the Softweare install is corrupted and if a re-install didn't fix it then try installing on a different OS
lfunk (Mechanical)
12 Aug 09 11:59
I discovered a solution to my error.  I turned off User Account Control (in Vista) and now I can get the model to analyze.  User Account Control usually prompts for permission to make any changes in Windows system files (or System32).  I suspect that Algor is using the Windows System32 folder for some files during analysis.  When I try to run an analysis with the User Account Control on, I get the error without any request for permission.

To remind you, I have been logged on as an administrator throughout so I don't know why I am being asked for permission.

Anyway, I turn off the User Account Control and it works for me.
LongLe (Specifier/Regulator) (OP)
1 Sep 09 11:56
So I ended up building a new machine and doing a fresh install of everything including FEA...so far so good...

New Specs:

Microsoft Windows XP 64bit
Intel Core i7 920 Overclock to 3.4ghz
12 GB DDR3 1600mhz
ATI FireVL 5100 (not sure if this is powerful enough)


Thanks for all your help and advice Guys!!!! You are the best smile
LongLe (Specifier/Regulator) (OP)
14 Sep 09 14:54
ok sooo a rebuild didnt work....I found the cause tho... Kinda of wierd...It was a group policy issue with Active Directory. Even tho my account was a part of the local admin group I was still unable to run it. I even ran Filemon and Regmon to try and track down if its something im getting to denied to, no luck there. As soon as I moved my user account into the NO GPO group. and Try running the MES Analysis agian works. So I have to review the GPO applied to the engineer OU. Well That resolved the issue for me...hope that helps out someone else as well.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!

Back To Forum

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close