Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Eng-Tips
*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Getting "Internal error: memory access violation" At File Open.Helpful Member! 

4mranch1 (Aerospace)
2 Aug 07 8:38
We are using NX3, running Windows XP, and are getting the following message as an assembly file is being opened:

--------------------------------------------
Hit OK to continue
Internal error: memory access violation
OK
--------------------------------------------

If OK is chosen and the same file is selected to open a second time, in the same session, the following message is displayed:

----------------------------------------------------------
Open Part
You chose to open T:\....\XXXXXX.prt.
This part is already loaded.

To see the currently loaded part, choose Change Displayed Part.
To reopen the currently loaded part, choose Reopen.
Change Displayed Part         Reopen         Cancel
----------------------------------------------------------

It does not matter if the Change Displayed Part or Reopen is chosen the assembly will open and display (Note: some of the components will not open and have to be selected in the ANT and then Open Component). The file can be edited and saved, but the same messages will pop up the next time it is chosen to open in a new session.

Secondly, the next higher assembly, when chosen to open in the same session, will give the exact same first error window, but upon succeeding tries will continue to give the same "Internal error: memory access violation" message.

The only way to open the next higher assembly is to close all files and then choose it to open. Then it goes thru the first and second error messages to get it open.

Thank you one and all for your input and advice in solving this problem.

Gary Ashby
Designer

cowski (Mechanical)
2 Aug 07 9:18
Have you run 'part cleanup'? Sometimes that will fix the problem.
4mranch1 (Aerospace)
2 Aug 07 9:57
Thanks for the input cowski. I just ran the "Part Clenup" again just to be sure I had and the same error messages pop up on open.

Gary Ashby
Designer

Xwheelguy (Automotive)
2 Aug 07 10:51
Gary,

I looked over the GTAC database for "memory access violation assembly" and received about 200 different results just for NX3.  It appears to me that this error is quite common but the solutions vary quite a bit from one situation to another and I feel you'd probably be best served by contacting GTAC.

Is installing a maintenance release or maintenance pack out of the question?  BTW, what is your exact NX3 version?  You can check by clicking Help -> About NX then click the System Information button on the dialog that comes up.

Thanks and sorry I could not offer a better suggestion.

Tim Flater
Senior Designer
Enkei America, Inc.
www.enkei.com

Some people are like slinkies....they don't really have a purpose, but they still bring a smile to your face when you push them down the stairs.

4mranch1 (Aerospace)
2 Aug 07 11:11
nkwheelguy,

We do have a UG support contact number (1-800-955-000), but thought I would give this forum a chance first. As for our exact release it is: NX 3.0.0.21

We are about to upgrade to NX5 so this problem may be dealt with in that release.

In the past with earlier versions this error could have been due to one bad model being used in the assembly, but all of our models are fairly simple and none show any sign of abnormality until the assembly is opened.

Thanks for your advice, I will give them a call after I attempt to solve this dilemma on my own or with help from this forum.

Gary Ashby
Designer

Helpful Member!  MSPBenson (Mechanical)
2 Aug 07 13:06
A couple of things to try.

Open the lowest level of sub assy that displays the error on opening.  Once open in the ANT right click on the assy node at the top and update structure.  It may take a while if it is a large assy.  Once updated save it and see if that fixes the problem.  It may display some useful info in the log that comes up at the end.

The second thing to try is to open the assy with no components.  does it give you the same error?
If not it could be a problem with one of the components.
Open each component using the ANT one at a time and see if a specific file sets off the error.
This at least can identify if it's a specific part.

These have worked for me in the past as this has been a problem with large assys that are updated frequently in previous versions of UG not just NX3.

Hope that helps,

 

Mark Benson
Aerodynamic Model Designer

4mranch1 (Aerospace)
2 Aug 07 14:29
Thanks MSPBenson, but your methods did not seem to make a difference.  Even though I updated as you suggested there were no messages in the log and the error persisted.

I tracked the problem down to the only (2) Wave Geometry Linked parts and the only (4) Deformed Parts used in the top assembly. When these 6 items are deleted and the assembly is saved ,it will Open without a hitch.

The first Linked_Body part consists of a gear blank that has the gearing cut at the next higher part level. This part then goes into the assembly.

The second Linked_Body part consists of two parts without holes that get combined to create a matched set with holes. This matched set (Assembly) then goes into the top assembly.

The last 4 are components that have been deformed at the top assembly (O-rings in grooves.)

I am currently trying to figure out how to straighten this problem out.

Gary Ashby
Designer

Xwheelguy (Automotive)
2 Aug 07 17:54
Gary,

A maintenance pack or maintenance release might be the answer here, if possible.  I'm pretty sure you're running a very early version of NX and unless I'm mistaken, there were a TON of issues with assemblies in the early stages of NX3.

I understand if that's not an option at this point in time, and that's about all I can offer as helping out.

Tim Flater
Senior Designer
Enkei America, Inc.
www.enkei.com

Some people are like slinkies....they don't really have a purpose, but they still bring a smile to your face when you push them down the stairs.

4mranch1 (Aerospace)
2 Aug 07 17:58
Removed the 4 deformed part o-rings and added them back into the assembly. Deformed them as needed. One o-ring was only added to the assembly so it would show up in the parts list so I had set it's Ref.Set to "Empty". This "Empty" Ref.Set seemed to be the culprit for the deformed parts. Now it resides in the assembly on an invisible layer and is not part of the assembly Ref.Set being used in the next assembly (Drawing).

As for the troublesome Waved Geometry models I changed them to Promoted instead and now the assembly saves and opens without the error message.

Gary Ashby
Designer

pinetti (Mechanical)
8 Aug 07 6:09
Gary,

We had this problem in the past often enought. For a long time we were not able to open any large assemblies.

What we finally did was:
1- Change the memory of XP. I don't understand much about this, but the idea is that whatever computer you have, XP only reach up to 1.5G of memory. There is something you can do to boost it up to 3G. Know, when we have to deal with something big, we start the computer this way.

2- Reduce the size of the files and check procedures. i.e. Do you net the whole component charging in the assembly? you can use FACET or other references.
Also, you may not need to have your complete design assambled, only smaller subassemblies.
hudson888 (Mechanical)
9 Aug 07 22:38
Using pretty much the same technology and some very large assemblies we found that some old Solid Edge files that had been uploaded into UG caused most of the problems. We eventually replaced the contents with UG data finding that it was more stable once the supposedly backwards compatible features were removed from the data.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!

Back To Forum

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close