Smart questions
Smart answers
Smart people
Join Eng-Tips Forums
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Eng-Tips
*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Fawkes (Mechanical) (OP)
21 Jun 05 9:04
I'm having trouble running the JLink samples.

I'm running wildfire 2.0 on windows xp pro.

I've run the following command at the c: prompt

set classpath=.;C:\Program Files\proeWildfire 2.0\text\java\pfc.jar;%classpath%

without any messages

When  I try to run javac *.java from the samples folder it tells me that javac is not recognised as an internal or external command.

When I try to run C:\Program Files\Java\jdk1.5.0_03\bin\javac *.java i get the message 'c:\program' is not  recognised as an internal or external command.

When I go to the jdk1.5.0_03\bin folder and run javac c:\program files\proewildfire 2.0\jlink\jlink_appls\install_test\*.java I get the message 'invalid flag: C:program '.

What is going on?

Why won't it work?


Helpful Member!  justkeepgiviner (Mechanical)
21 Jun 05 10:31
Try reinstalling Pro/E to a folder without spaces in its name(i.e. c:\ptc\proewildfire2\...)

From the sounds of it, J-Link thinks the location string ends with the space.

I managed to make the demos work at our old office, and all of our Pro/E Installations were in folders like the one I stated above. We never really got into our own J-Link customization due to time constraints, though.
justkeepgiviner (Mechanical)
21 Jun 05 10:34
Sorry, forgot to include this...

I believe you also need to set a CLASSPATH environment variable that points it to the Java Runtime Environment as well. Unfortunately I don't have any documentation any more so I am strictly going on memory.
Fawkes (Mechanical) (OP)
21 Jun 05 11:12
Thanks for the tip, I used the dir /x flag to show the short names (folder/file names without spaces) and used those.

The java files have now compiled but I still get an 'Installation failed' message?
Fawkes (Mechanical) (OP)
21 Jun 05 11:17
If I use NetBeans to try and review the pfcInstallTest.java file it tells me that the package com.ptc.pfc.pfcSession does not exist.
Fawkes (Mechanical) (OP)
22 Jun 05 9:39
It appears that I might not have a licence to run JLink as I'm only running an evaluation copy.

Does anyone know how I check to see if I have a licence to run JLink?
Fawkes (Mechanical) (OP)
1 Jul 05 5:18
JLink doesn't work with Java JDK 1.5, you need 1.4.2
williaps (Computer)
8 Aug 05 9:08
You don't need a license to compile and run jlink applications.  If you are using netbeans 4.1 then to add the package execute the following steps:
1.  Right click on your project and click properties.
2.  Click the 'Libraries' category.
3.  Click the 'Add JAR/Folder'.
4.  Browse to the pfc.jar (c:\ptc\pro\text\java\pfc.jar) and add it.
5.  Rebuild and the pfcSession should be defined.

Reply To This Thread

Posting in the Eng-Tips forums is a member-only feature.

Click Here to join Eng-Tips and talk with other members!

Back To Forum

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close