Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR ENGINEERING PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you an
Engineering professional?
Join Eng-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Eng-Tips
*Eng-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

General Solidworks How to's

Are you experiencing Slow downs? - Try these options
Posted: 9 Mar 05 (Edited 18 Nov 05)

This is what I suggest for you fix, remove, or repair on your system(s).
 
1) Turn Animated Icons off and use a standard mouse cursor. Extra memory and graphics RAM being used on something not needed – Sounds petty but it does improve performance.

2) Was an Anti-Virus running when SW was installed? If it was, a reinstall would probably need to be done. AV can cause some files to not be installed and SW performance and stability can be compromised.

3) If you have numerous processes running at an excess of 40. Reduce that number to at least 31. Some sites to help you with processes running
Blackviper_XP - XP
Blackviper_2K- Win 2000

4) Remove and uninstall all applications that are not needed (Shareware programs) like the Weather bug, etc… - These Applications use up needed RAM for other more important apps. Some Shareware programs have Hijackers in them and can cause further slow downs of your network and Internet activity.

5) Check for Hijackers and spy bots. These items can cause memory loss and unneeded network traffic.

6) Cut out the complexity of your models. - e.g.: If you are not a chain maker, don’t make all the links and place them in your models. Make a solid band to represent a chain.

7) If there is a rebuild light in your part model or of an assembly. This will slow the system down, because it tries to rebuild file in the process of it opening.

8) Any errors in a model will cause slow downs in your opening process.

9) If you are exceeding the amount of RAM you have, you will start paging the HDD it will become a lot slower in opening the file and working with it from there.

10) Clean your TEMP folders out regularly. http://www.scottjbaugh.com/Tips_Tricks/Computer_Maintenance.htm

11) Is you Minimum and Maximum Virtual Memory set to the same value? It should be, so too not allow the file to grow in size.

12) http://www.solidworks.com/swexpress/mar04/200403_techtip_02.cfm - Check here for “Overall System Performance”

13) Is your video card and driver certified?

14) Is it an older video card that is supported? If its old, it may not really support large assemblies. There are certain graphics cards for these types of workloads that you do. – e.g.: The Quadro 500 FX is a low-end card for SW. Works well with about 50-100 Component assemblies. Quadro 1100 FX is a Mid-Range video card. It works well with more complex Assemblies maybe 100-1000+ components. Quadro 3000 or 4000 FX are the high-end cards and should support larger assemblies of 1000+. SW supports all of these cards, but each out performs the other lower one.

15) If you are opening the files over a network, you should really try and open them locally, but if that is an issue for you. Then there have been some discussions of Network problems and possible fixes on the web – Here is on for example: http://www.eng-tips.com/viewthread.cfm?qid=51547

16) PDMworks will also help you and should be highly considered if you continue to work the way that you do now.

17) Maybe enabling the 3GB switch in XP might help you out - http://www.amiravis.com/3GBswitch-instruction.html - This is a use at your own risk.

18) What is your CPU size or speed? If it isn’t up to date, you might consider moving up to a faster CPU of today.

19) If you have a system that has Hyper-threading enabled. Disable it in the Boot up process. This allow SW to use the entire CPU, instead of only half of it.
 
20) Increase your RAM to what the Motherboard will support – I don’t recommend anything under 1.5 GB for SW05.

21) What is the number of your Top-level mates? It should not exceed 300. If it does then you are going to take a performance hit. To lessen the number of top-level mates, make more sub-assemblies. For every one part you must have at least 3 mates to define a part. If you 125 parts in an assembly, that equals to 375 mates. If you make those 125 parts into 6 sub-assemblies, that equals 18 mates in total. That lets SW rebuild only 18 mates versus 375 when opening. This will increase performance and open times.

22) If you are having network related issues while working over a network. You should consider getting the Engineering group off the main Network and have them work on their own network, but still have access to the rest of the company.

23) Test run an assembly on your local drive to see if your performance increases and the amount of memory being used is not exceeding the amount you have? This is recommended to ensure the issue is network related.

I’m sure some the options above will help in keeping your Assemblies running smoother.

Regards,

Back to DASSAULT: SOLIDWORKS 3D Design FAQ Index
Back to DASSAULT: SOLIDWORKS 3D Design Forum

My Archive

Close Box

Join Eng-Tips® Today!

Join your peers on the Internet's largest technical engineering professional community.
It's easy to join and it's free.

Here's Why Members Love Eng-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close